Formule pour récupérer toutes les données avec 1 valeur

Bonjour,

Voici ma petite demande.

Je souhaiterais récupérer toutes les « lignes » correspondantes aux « données », c'est-à-dire que je souhaite récupérer dans la colonne G, toutes les « lignes » de A, puis dans I toutes les lignes de B…etc.

Il y a des centaines de « données » et elles peuvent toutes avoir des formes différentes, par contre, les « lignes » sont toujours comme cela.

La valeur MAX est tout en haut, puis se chiffre se décrémente à chaque ligne.

Toutes les données A se suivent, puis toutes les données b se suivent… etc.

Je souhaiterais uniquement avec une formule, pas de formule matricielle ou de macro.

S’il n’y a pas le choix, alors je sais changer d’avis !

Merci d’avance.

32kim.xlsx (12.04 Ko)

Bonjour,

Une proposition à la six-quatre-deux, si j'ai bien compris.

En attendant qu'un bulbe rachidien n'intervienne.

Cdlt.

19kim.xlsx (31.76 Ko)

Bonjour. une alternative avec formule


Fonctionnant également

Première ligne =DECALER(A1;EQUIV($F$1;données;0)-1;1)

Deuxième ligne =SIERREUR(SI(DECALER($A$1;(EQUIV(G2;ligne;0)+1);)=$F$1;INDEX(ligne;EQUIV(G2;ligne;0)+1);"");"")

35kim.xlsx (28.09 Ko)

Bonjour,

je me suis servi de la proposition de Wilder, et ça marche super, merci.

8)

ptite autre question.

comment faire, à partir d'une donnée pour récupérer l'information en ligna 1,

par exemple, comment je peux récupérer l'information "ligne" avec 862 ou 861?

merci d'avance.

Probablement avec la fonction equiv() mais je ne comprends pas trop la question donc sous reserve

c'est bon, réussi et oui, avec tout simplement un equiv...

merci à toi!

Ok

Rechercher des sujets similaires à "formule recuperer toutes donnees valeur"