Recherche V qui passe pas

Y compris Power BI, Power Query et toute autre question en lien avec Excel
W
Willou
Membre fidèle
Membre fidèle
Messages : 153
Inscrit le : 16 août 2018
Version d'Excel : 2016

Message par Willou » 22 août 2018, 13:44

Bonjour,

Ma recherche V devrait fonctionner mais elle bloque :
=SIERREUR(RECHERCHEV(I307*1;'Merkleinc Datafeeds FY19Q2 wk12'!$D$1:$E$28527;2;1);"")

Je vous ai mis le fichier en pièce jointe
1e onglet colonne G qui doit aller chercher les données en colonne E
ARP Nederland B.V.devrait avoir une correspondance

Merci
T
Recherche V problème.xlsx
(933.31 Kio) Téléchargé 11 fois
U
U. Milité
Membre impliqué
Membre impliqué
Messages : 2'038
Appréciations reçues : 143
Inscrit le : 30 novembre 2016
Version d'Excel : Office 365

Message par U. Milité » 22 août 2018, 14:03

Bonjour,

Et à quoi correspond le '1' au 4e argument de ta RECHERCHEV ??
a
anne64
Jeune membre
Jeune membre
Messages : 46
Inscrit le : 6 novembre 2017
Version d'Excel : 2013

Message par anne64 » 22 août 2018, 14:05

Je ne comprends pas où doit se trouver ta formule, quelle cellule ?
W
Willou
Membre fidèle
Membre fidèle
Messages : 153
Inscrit le : 16 août 2018
Version d'Excel : 2016

Message par Willou » 22 août 2018, 14:10

anne64 a écrit :
22 août 2018, 14:05
Je ne comprends pas où doit se trouver ta formule, quelle cellule ?
[/quote

La formule doit se trouver dans la colonne L de l'onglet Datav2
W
Willou
Membre fidèle
Membre fidèle
Messages : 153
Inscrit le : 16 août 2018
Version d'Excel : 2016

Message par Willou » 22 août 2018, 14:12

U. Milité a écrit :
22 août 2018, 14:03
Bonjour,

Et à quoi correspond le '1' au 4e argument de ta RECHERCHEV ??
Je ne sais pas vraiment. Un membre du forum me l'a donnée et ça a permis de faire passer la formule ailleurs. Sans cela ne donne aucun résultat.
W
Willou
Membre fidèle
Membre fidèle
Messages : 153
Inscrit le : 16 août 2018
Version d'Excel : 2016

Message par Willou » 22 août 2018, 14:33

J'ai besoin de 2 recherche v :
une en colonne K de l'onglet Data v2
une en colonne L de l'onglet Data v2
En colonne K =SIERREUR(RECHERCHEV(H2;'Merkleinc Datafeeds FY19Q2 wk12'!$A$1:$B$30000;2;1);"") ne donne aucun résultat.

Pourquoi ? Cela n'a pas de sens
m
massari59264
Membre fidèle
Membre fidèle
Messages : 474
Appréciations reçues : 8
Inscrit le : 29 avril 2017
Version d'Excel : 2016

Message par massari59264 » 22 août 2018, 14:50

En colonne k2 la formule est :
=SIERREUR(RECHERCHEV(H2*1;'Merkleinc Datafeeds FY19Q2 wk12'!$A$1:$B$28527;2;1);"")
et en colonne L2 la formule est :
=SIERREUR(RECHERCHEV(I2;'Merkleinc Datafeeds FY19Q2 wk12'!$D$1:$E$28527;2;1);"")
Il ne faut par * par 1 pour ta deuxième recherche, la valeur cherchée est du texte,

Cordialement,
Avatar du membre
fravain
Jeune membre
Jeune membre
Messages : 10
Appréciation reçue : 1
Inscrit le : 7 août 2018
Version d'Excel : 2010

Message par fravain » 22 août 2018, 14:57

Copie de Recherche V problème.xlsx
(993.61 Kio) Téléchargé 9 fois
frv.
U
U. Milité
Membre impliqué
Membre impliqué
Messages : 2'038
Appréciations reçues : 143
Inscrit le : 30 novembre 2016
Version d'Excel : Office 365

Message par U. Milité » 22 août 2018, 15:01

Re-bonjour,

Eh bé, y a du monde ! :? Bonjour à toutes et tous,
Willou a écrit :
22 août 2018, 14:12
U. Milité a écrit :
22 août 2018, 14:03
Et à quoi correspond le '1' au 4e argument de ta RECHERCHEV ??
Je ne sais pas vraiment. Un membre du forum me l'a donnée et ça a permis de faire passer la formule ailleurs. Sans cela ne donne aucun résultat.
Le 4e argument de RECHERCHEV permet de déterminer si on veut trouver la correspondance exacte entre la valeur cherchée et la colonne de gauche de la table_matrice. Pour trouver la correspondance exacte, il faut indiquer FAUX ou 0 pour la Valeur_proche. En mettant 1, tu risques bien d'obtenir des résultats "fantaisistes"
W
Willou
Membre fidèle
Membre fidèle
Messages : 153
Inscrit le : 16 août 2018
Version d'Excel : 2016

Message par Willou » 22 août 2018, 15:47

Merci beaucoup pour votre aide.
En colonne K j'ai : =SIERREUR(RECHERCHEV(H2*1;'Merkleinc Datafeeds FY19Q2 wk12'!$A$1:$B$29999;2;1);"")
En colonne L j'ai : =SIERREUR(RECHERCHEV(I2;'Merkleinc Datafeeds FY19Q2 wk12'!$D$1:$E$28527;2;1);"")

Pourquoi est ce que je trouve des résultats totalement différents ?
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message