Contôle d'occurence et comparaison VBA

Y compris Writer et toute autre question en lien avec les suites bureautiques Open Source
B
Bryard
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 16 janvier 2019
Version d'Excel : 2013 FR

Message par Bryard » 16 janvier 2019, 08:08

Bonjour à tous,

Je souhaiterai réaliser un contrôle par macro VBA sur deux colonnes Excel :

Colonne A Colonne B

15654789 LL01-5634
15654789 LL01-5634
15654789 MP01-5464

si dans col A j'ai 15654789 et dans col B LL01-5634 alors je veux vérifier qu'à chaque fois que j'aurai 15654789 dans ma col A j'aurai LL01-5634 dans ma col B sinon je renvoie un message d'erreur. je souhaiterai généraliser cela avec plusieurs références différentes dans Col A
j'ai pu le faire manuellement comme ceci :

=SI(NB.SI($A$2:A2;A2)=NB.SI.ENS($A$2:A2;A2;$G$2:G2;B2);"OK";"KO")

Merci beaucoup !!!
Avatar du membre
Juice
Membre impliqué
Membre impliqué
Messages : 1'132
Appréciations reçues : 100
Inscrit le : 28 novembre 2017
Version d'Excel : Microsoft Excel 2010

Message par Juice » 16 janvier 2019, 11:15

Salut Bryard et bienvenue sur le Fofo!
Salut le Fofo!

Ci-joint un fichier test qui affiche un message d'erreur si il y a des valeurs différentes en colonne B alors que les valeurs en colonne A sont identiques

Le message d'erreur indique le numéro de ligne, et les valeurs présentes en colonne B, et il permet de choisir de quelle manière l'erreur est géré :

- Poursuivre la procédure sans modifier
- Quitter la procédure sans modifier
- Modifier en colonne B, la valeur x par la valeur y
- Modifier en colonne B, la valeur y par la valeur x

Voilà voilà, je te laisse tester et revenir vers nous!
Pour Bryard.xlsm
(21.43 Kio) Téléchargé 8 fois
A l'instant même où je l'ai vue, ingénue,
Je suis tombé amoureux d'eeeeeeelle.
Elle est la seule ici bas,
Que je trouve digne de moi.
Et je compte bien épouser cette demoiseeeeelle.

La Belle et la Bête. Belle
B
Bryard
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 16 janvier 2019
Version d'Excel : 2013 FR

Message par Bryard » 16 janvier 2019, 15:51

Merci beaucoup juice :) je vais tester tout cela
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message