Contôle d'occurence et comparaison VBA

Bonjour à tous,

Je souhaiterai réaliser un contrôle par macro VBA sur deux colonnes Excel :

Colonne A Colonne B

15654789 LL01-5634

15654789 LL01-5634

15654789 MP01-5464

si dans col A j'ai 15654789 et dans col B LL01-5634 alors je veux vérifier qu'à chaque fois que j'aurai 15654789 dans ma col A j'aurai LL01-5634 dans ma col B sinon je renvoie un message d'erreur. je souhaiterai généraliser cela avec plusieurs références différentes dans Col A

j'ai pu le faire manuellement comme ceci :

=SI(NB.SI($A$2:A2;A2)=NB.SI.ENS($A$2:A2;A2;$G$2:G2;B2);"OK";"KO")

Merci beaucoup !!!

Salut Bryard et bienvenue sur le Fofo!

Salut le Fofo!

Ci-joint un fichier test qui affiche un message d'erreur si il y a des valeurs différentes en colonne B alors que les valeurs en colonne A sont identiques

Le message d'erreur indique le numéro de ligne, et les valeurs présentes en colonne B, et il permet de choisir de quelle manière l'erreur est géré :

  • Poursuivre la procédure sans modifier
  • Quitter la procédure sans modifier
  • Modifier en colonne B, la valeur x par la valeur y
  • Modifier en colonne B, la valeur y par la valeur x

Voilà voilà, je te laisse tester et revenir vers nous!

14pour-bryard.xlsm (21.43 Ko)

Merci beaucoup juice je vais tester tout cela

Rechercher des sujets similaires à "contole occurence comparaison vba"