Traitement de données

bonjour,

je dispose d'un fichier avec en colonne B des numéros qui arrivent et en colonne E à O des calculs qui se font au fur et à mesure qu'un numéro arrive à la suite en colonne B.

je n'ai mis que 4 lignes car ce que je voudrais se travaille sur 4 lignes.

en b7 nous avons le dernier numéro (33) il faut donc prendre l'avant dernier donc le 28 et chercher s'il se trouve dans la ligne ou il y a le 11 en B5.

s'il on trouve le 28 alors il faut relever le numéro de dessus et dessous donc ici le 19-57 et les inscrire en C7-D7.

merci pour votre aide.

2test.xlsm (8.79 Ko)

Bonjour,

je n'ai mis que 4 lignes car ce que je voudrais se travaille sur 4 lignes

Tu ne dis pas s'il pourra y en avoir une 5e, 6e, etc. Par défaut, j'ai considéré que oui. Si pas, on peut simplifier un petit peu.

Avec ce que j'ai compris ...

En C11:

=SI(NBVAL(B8:B10)<3;"";SI(NB.SI(E9:O9;B10);INDEX(E10:O10;EQUIV(B10;E9:O9;0));""))

à recopier vers le bas.

En D11:

=SI(NBVAL(B8:B10)<3;"";SI(NB.SI(E9:O9;B10);INDEX(E8:O8;EQUIV(B10;E9:O9;0));""))

Bonjour,

Super c'est pile poil ce que je voulais

Vous êtes trop fort.

Bonne journée

Rechercher des sujets similaires à "traitement donnees"