Somme tant que

Bonjour

Voici en colonne B le resultat que je voudrais obtenir.

Si A1= 0 alors on met zero mais si A1 =1 on doit faire la somme de tous les éléments successif de la colonne A tant qu'il n' y a pas de zero.

Par exempl en B5 on a 4 car le calcul est A5+A6+A7+A8 = 4, la cellule A9 etant egale a zero n'est pas prise en compte dans la somme.

Il faudrait je pense une macro boucle "tant que..."

merci pour votre aide

Bonjour,

au plus simple en VBA

Bonjour,

Formule qui renvoie le résultat recherché :

=SOMME(DECALER(A1;;;SIERREUR(EQUIV(0;A1:$A$13;0);LIGNES(A1:$A$13))))

Cordialement.

Bonjour,

au plus simple en VBA

Somme tant que.xlsm

Salut M12

Super!! c'est ce que je voulais

peux-tu juste m'expliquer a quoi ça sert de mettre des % juste après les variables ?

Bonjour,

Formule qui renvoie le résultat recherché :

=SOMME(DECALER(A1;;;SIERREUR(EQUIV(0;A1:$A$13;0);LIGNES(A1:$A$13))))

Cordialement.

super M Ferrand

jte remercie

je vais decortiquer la formule et je reviens vers toi si j'ai des questions

en tout cas bravo !!

Bonjour,

au plus simple en VBA

Somme tant que.xlsm

Salut M12

Super!! c'est ce que je voulais

peux-tu juste m'expliquer a quoi ça sert de mettre des % juste après les variables ?

C'est la déclaration de la variable en raccourci

au lieu de mettre "As Integer" (est un entier)

Bonjour,

au plus simple en VBA

Somme tant que.xlsm

Salut M12

Super!! c'est ce que je voulais

peux-tu juste m'expliquer a quoi ça sert de mettre des % juste après les variables ?

C'est la déclaration de la variable en raccourci

au lieu de mettre "As Integer" (est un entier)

merci M12

Y a t'il d'autres raccourci en declaration de variable ? pour as Long ou as string par exemple ?

Bonjour

Regarde ici, tu auras tout ce que tu désires

https://www.excel-pratique.com/fr/vba/variables.php

Bonjour

Regarde ici, tu auras tout ce que tu désires

https://www.excel-pratique.com/fr/vba/variables.php

TOP !

jte remercie

Rechercher des sujets similaires à "somme tant que"