Somme sur la première valeur valide - VBA

Bonjour,

Je cherche dans mon fichier à obtenir le prix le plus intéressant parmi 4 prix , qui sont classés par ordre croissant , soit le moins cher en premier mais il y'a des cellules à zero. Je pensais faire un SUMIF mais mes compétences sont limitées et je n'arrive pas à sortir un code...

Mais un fichier Excel vaut mieux qu'un long discours mon doc joint ci-dessous.

4test.xlsx (15.22 Ko)

Salut,

Une idée pour ma part,

Girodo

4test.xlsx (15.92 Ko)

Bonjour Girodo,

Merci pour ta formule mais j'aimerais le faire en VBA .

Pour info j'utilise celle ci en ce moment =SI(SI(SI(C2<>0;C2;D2)<>0;SI(C2<>0;C2;D2);E2)<>0;SI(SI(C2<>0;C2;D2)<>0;SI(C2<>0;C2;D2);E2);F2)

Cdlt

Bonjour,

L'utilisation de VBA entraine pas mal de contraintes notamment en cas de changement de PC ou d'utilisation du classeur par quelqu'un qui n'y connait rien. Je ne comprend donc pas pourquoi vouloir forcément passer à VBA quand une solution par formule fonctionne.

Bref si tu insiste et argumente je veux bien regarder

Girodo,

Rechercher des sujets similaires à "somme premiere valeur valide vba"