Somme = 0 . Comment cela se fait ?

Bonjour à tous,

Je suis confronté à un petit soucis.

En effet, dans ma feuille de calcul, j'ai la formule suivante : =SI([@[Clientèle 0 / Exploit 1]]="";"0";"0,5")

Mais lorsque j'effectue le tableau dynamique, celui ci me donne 0 en résultat de somme.

J'ai donc essayé dans un autre classeur en simplifiant mon fichier => voir fichier joint !

En colonne A : Texte "Exploitation" ou Clientèle"

En colonne B : =SI(A1="Exploitation";"1";"0") (j'ai volontairement changer les retour valeurs pour voir si c'était le problème )

En colonne C, j'ai juste =SOMME(B2:B20)

Malheureusement dans ce fichier j'ai toujours le problème et je ne comprends pas le pourquoi car j'ai bien mis en forme nombre.

Je vous sollicite donc afin d'arriver à comprendre pourquoi cela me fait cela .

Merci par avance pour les réponses

5classeur2.xlsx (9.77 Ko)

Salut,

C'est lié à ta formule en colonne B. Enlèves tes "" sinon excel considère tes chiffres 1 et 0 comme du texte.

Si tu demandes à excel de faire 1 + 1 + 0 il répondra 2, si tu lui demande de faire un + un + zéro il ne sait pas !

La bonne formule : =SI(A10="Exploitation";1;0)

Bonne journée,

Bonjour,

=SI(A1="Exploitation";"1";"0")  

En mettant le 1 et le 0 entre guillemets > ils sont considérés comme du texte ...

Essai > =SI(A1="Exploitation";1;0) ...

ric

ho purée, merci bien.

Cela m'est même pas venu à l'esprit que je mettais les valeurs en texte.

Super, merci à vous !

Rechercher des sujets similaires à "somme comment cela fait"