Si(recherchev avec un format "spécial"

Bonjour @toutes et tous.

Voila je combine une recherchev mais je voudrais qu'il recherche en fonction d'une valeur (un codebarre)
en fait : A1 peut soit avoir un gencod (13chiffres), soit une référence
donc je voudrais faire une recherche en fonction de , qui serait si(a1=13chiffres;recherchev(xx;5;faux);recherchev(xx;4;faux))
Auriez vous une piste pour l'identification de cette différence ? (13 chiffres / autres)

Par avance, merci

bonjour,

essaie ceci

=SI(ET(ESTNUM(A1);NBCAR(A1)=13);recherchev(xx;5;faux);recherchev(xx;4;faux))

Bonjour h2so4,

désolé de revenir si tard sur le dossier, (je n'avais pas mon ordi).

La fonction ne marche pas mallheureusement .

voila la formule réécrite : =SI(ET(ESTNUM(A5);NBCAR(A5)=13);RECHERCHEV(Stock[[#Tout];[EAN]:[Nom(2)]];2;FAUX);RECHERCHEV(Stock[[#Tout];[Produits]:[Nom]];2;FAUX))
en fait le résultat met #Valeur!

bonjour,

ceci fonctionne-t-il ?

=SI(ET(ESTNUM(A1);NBCAR(A1)=13);"gencod";"reference")

sinon merci de mettre ton fichier ou un fichier exemple dans lequel tu as pu reproduire le problème.

Bonjour,
en simple formule comme la tienne, cela fonctionne.
en "double" recherchev ca ne marche pas.

effectivement en mettant le fichier cela est plus rapide

le voici

2fdv-3-1.xlsm (246.24 Ko)

bonjour,

ce sont tes formules recherchev qui ne sont pas correctes.

1fdv-3-1.xlsm (242.83 Ko)

j'ai vu mon erreur, merci
Par contre je n'arrive pas à integrer le sierreur
car lorsque A5 est vide ca m'est #N/a

bonjour, à tester

1fdv-3-1.xlsm (243.00 Ko)

Super, merci cela fonctionne. :)

Rechercher des sujets similaires à "recherchev format special"