Si imbriqué : estvide ou pas

Bonjour les experts !

Petit besoin ponctuel => je n'arrive pas à tomber en accord sur la syntaxe de formule pour la problématique suivante :

------A------------B

1--2019----------

2--2018 ----Client X

3--Check => "OK" ou "!!" (ici "!!")

Voila le deal : Je souhaiterais un pop up automatique "OK" en B3 dans le cas où

  • il y a un client en 2018 ET 2019
  • il y a un client en 2019 mais pas en 2018

A l'inverse, le scénario client 2018 mais pas de client 2019 = "!!"

(scénario le plus important à notifier)

Mille mercis par avance !

Bien à vous

Cyril

Bonjour,

on aime bien avoir des fichiers joints aux demandes

ça va, la demande est simple à comprendre, donc je t'ai fait un fichier, je te le passe:

2conditions.xlsx (7.94 Ko)

La formule: =SI(B1<>"";"OK";SI(ET(B2<>"";B1="");"!!";""))

Voir si 2019 est rempli, ou si 2019 et 2018 sont remplis, ça revient juste à regarder si 2019 est rempli pour moi

Du coup je n'ai mis que deux conditions dans ma formule: 2019 rempli? -> OK sinon : 2018 remplis mais pas 2019? -> !! sinon : ""

Bonjour,

Dans ton exemple En B1 tu as un "Tiret"

Il y aura toujours un Tiret quand il n'y a pas de client ou la cellule est vide quand il n'y a pas de client ?

Sinon c'est différent !

dans la formule à Ausecour en B3 c'est =si(B1<>"-"

@Ausecour : la mayonnaise a prit, c'est impec'. En effet, le cheminement logique peut en revenir à ça Merci !

@Xmenpl : les tirets étaient un simple mise en forme pour le message chat , à défaut de fournir une PJ

Encore merci à vous !

My best

Cyril

Re, bonjour Xmenpl

La remarque est pertinente, une cellule vide = un tiret, ou c'est juste un format d'affichage de cellule type : #;-#;"-" ?

Parce que ça change la formule si ce n'est pas qu'un format d'affichage...

EDIT:

Ah eh bien tu as répondu!

Super si c'est bon

Rechercher des sujets similaires à "imbrique estvide pas"