Si contient alors soustraire

Bonjour,

J'essaie de réaliser une formule si contient alors soustraire mais à chaque fois que je l'applique cela ne fonctionne pas comme je veux.

Je souhaiterais faire si la cellule C1 (par exemple) contient un chiffre finissant par 2 alors dans la cellule H1 enlever 1 à ce chiffre.

J'ai réalisé la formule suivante SI(DROITE(C1;1)=2;C1-1;C1), mais je n'obtiens pas mon résultat souhaité.

A chaque fois la formule me recopie la cellule C1.

Merci pour votre aide.

Seb92110

5test.xlsx (8.32 Ko)

Bonjour le forum,

=SI(--DROITE(C1;1)=2;C1-1;C1)

Bonjour,

Tu as oublié les guillemets sur le 2...

SI(DROITE(C1;1)="2";C1-1;C1)

christelle

Bonjour le forum,

=SI(--DROITE(C1;1)=2;C1-1;C1)

Bonjour mbbp...

c'est quoi cette petite astuce

christelle

Bonjour teten1,

-- donne le même résultat que *1

=SI(DROITE(C1;1)*1=2;C1-1;C1)

Merci pour votre aide.

J'ai modifié la formule et ce la fonctionne très bien.

Rechercher des sujets similaires à "contient soustraire"