SI cellule contient texte quelconque alors

Bonjour,

Question d'un néophyte.

Tout est expliqué dans le fichier excel joint.

Merci d'avance

114testcantons.xlsx (10.61 Ko)

Bonjour la Suisse,

Attention, une formule ne peut pas se mettre (sauf VBA) à la place d'une valeur existante ... j'ai donc ajouté une colonne.

Si tu tries la colonne 1 selon tes critères, mais aussi la colonne 2 de A à Z, alors tu as cette formule :

=SI(B2="";INDEX(B:B;EQUIV(A2;A:A;0));B2)

Maintenant on peut aussi le faire en VBA (et sans avoir besoin de trier la colonne 2)

48testcantons.xlsx (10.88 Ko)

Bonjour 789_excel, Steelson,

je te retourne ton fichier modifié :

103testcantons.xlsm (16.95 Ko)

Ctrl e ➯ travail effectué !


Alt F11 pour voir le code VBA, puis revenir sur Excel

si besoin, tu peux demander une adaptation.

merci de me dire si ça te convient.

dhany

Re-bonjour,

Ben ça alors! Y'a vraiment des personnes douées!

Ça fonctionne nickel.

Mille fois merci.

j'étais en pause, et j'viens d'lire ton post.

merci pour ton retour, et pour avoir passé le sujet en résolu !

bonne continuation !

dhany

Rechercher des sujets similaires à "contient texte quelconque"