Remplacer une formule par du VBA dans une colonne

Bonjour à toutes et tous,

Ayant quelques faiblesses en VBA et c'est peu de le dire.

Je souhaiterais avoir votre aide pour remplacer une formule dans la colonne "I" à partir de "I3".

Voici la formule que j'utilise pour mes calculs, mais elle est très gourmande en ressource.

=SIERREUR(INDEX(H$1:H$10000;AGREGAT(15;6;(1/((C$3:C$10000=$C3)))*(LIGNE(C$3:C$10000));LIGNE(A$1)))-SOMMEPROD((C$3:C$10000=$C3)*(B$3:B$10000<=$B3)*J$3:J$10000);0) 

Est-il possible d'avoir un code VBA ou une fonction personnalisée ?

Voici mon fichier exemple.

6exemple.xlsm (11.78 Ko)

Par avance merci.

Cordialement.

Salut,

Cette formule en I3 ne conviendrait-elle pas ? (A Glisser vers le bas par la suite)

=H3-SOMME.SI(C$3:C3;C3;J$3:J3)

Girodo,

Bonsoir Girodo,

Pourquoi ais-je été chercher si loin, ta formule est parfaite, merci.

Toutefois si un VBAbiste passe par là, je veux bien aussi avoir cette solution.

Cdlt.

Rechercher des sujets similaires à "remplacer formule vba colonne"