Remplacement valeur cellule vide

bonjour l'équipe

bon voilà j'ai un fichier excel comme suit :

colonne Acolonne B
1date&heure
donnée
201/01/2019 à 00:00
10
301/01/2019 à 01:0015
401/01/2019 à 02:0012
5......

25

02/01/2019 à 00:005
2602/01/2019 à 01:00
2702/01/2019 à 02:008
bon c'est une base de données assez volumineuse recensant pour chaque heure de chaque journée une valeur bien précise et cela pour toute une année soit du 01/01 au 31/12 ; alors voilà je cherche une formule qui me permettra de remplacer les cellules vides de la colonne B par la valeur de la journée J-1 correspondant à la même heure ; dans ce tableau par exemple, la cellule (26;2) est vide alors je veux que la formule la remplace par la valeur de la cellule (4,2) et ainsi de suite pour toutes les cellules vides.
PS : je ne suis pas très doué en excel aencore moins avec les macros :(((((((( alors merci de votre aide.
merci d'avance

Bonjour Walid

Quel est le format de la colonne A ? est-ce du texte ou est-ce numérique ? le traitement ne sera pas le même !

edit : et si tu avais un fichier, ce serait mieux !

Bonjour walid,

Si je vous ai bien compris, vous pouvez tester la solution suivante

1) utilisez le format de cellule :

JJ/MM/AAAA" à "HH:MM

en colonne B

2) mettez la formule suivante en colonne D :

=SI(ESTNUM(INDIRECT(ADRESSE(LIGNE();3);1));"";INDIRECT("C"&EQUIV(INDIRECT(ADRESSE(LIGNE();2);1)-1;B:B;0);1))
walid

Bonjour Steelson

exemple un poil diffèrent avec decaler si toutes les cellules se suivent heure par heure

=SI(C25="";DECALER(C25;-23;);C25)

mais encore une fois il faudrait connaître le format de ta colonne date

2walid.xlsx (10.07 Ko)

bonjour njhub

merci l'équipe pour votre célérité

pour faire simple, ci-joint le fichier excel sur lequel je travaille ; alors vous allez voir qu'à la date du 24/04/2019 12:00:00 correspond une cellule vide alors je voudrais que la formule ramène la valeur du 23/04/2019 12:00:00 si elle existe sinon celle du 22/04/2019 12:00:00 et ainsi de suite ; donc voilà y a pas mal de cellules vides dans la colonne B alors de préférence la formule pourrait être glissée sans écraser les valeurs des cellules pleines ; elle s'attaque qu'aux cellules vides

PS : vu que je maitrise pas les macros donc je vous ai expliqué ce que je recherche terre à terre

merci beaucoup

3draft.xlsx (132.57 Ko)

Bonjour walid,

Voyez le fichier traité en pièce jointe

4walid-draft.xlsx (147.52 Ko)

merci njhub pour l'effort mais au fait je pense qu'il y a erreur pour le mois de Mai :(((

alors ta formule affiche des " 0 " à partir du 02/05/2019 00:00:00 parce que la journée N-1 possède des cellules vides alors que normalement les cellules doivent reprendre les valeurs nouvellement déduites donc celles du 01/05/2019....

j'ai trouvé en tout cas les mêmes résultats que toi gräce à la formule de Steelson ....

PS : stp si tu trouves la solution laisse moi la formule parce que j'ai à peu près 2200 colonnes à corriger :(

merci

Walid,

un autre essai dans ce cas ...

=SI(B25="";DECALER(C25;-23;);B25)

2draft.xlsx (223.85 Ko)

SUPER, c'est parfait

merci les gars :) :) :)

N'oublie pas de clore le sujet en cliquant sur

Ok ça marche 👌👍

Rechercher des sujets similaires à "remplacement valeur vide"