Récupérer les données des doublons

Bonjour le forum,

dans le cadre d'un travail que je prépare, j'aurais besoin de récupérer sur ma feuille("données"), en cellule ("G7") la deuxième valeur correspondant à la baguette carrée soit ici pour l'exemple => 8x8, puis sur la colonne à droite => 10x10 et ainsi de suite.

Ma question : y a t-il une solution de faire ça ? J'avais pensé à "RechercheV" mais cela me donne toujours la même valeur et c'est logique.

Quelqu'un pour m'aider ?

Merci d'avance

3exemple.xlsm (19.17 Ko)

Bonjour,

En F7:

=SIERREUR(INDEX(produits!$B$2:$B$20;PETITE.VALEUR(SI(produits!$A$2:$A$20=$E7;LIGNE(produits!$A$2:$A$20)-1);COLONNES($A:A)));"")

Valider à l'aide de Ctrl+Shift+Enter (des accolades doivent encadrer la formule, dans la barre de formule, suite à cette validation). Copier ensuite vers le bas et à droite, aussi loin que nécessaire.

Attention, les formules matricielles comme celle-là sont gourmandes en ressources machine. Ne pas les utiliser sur de gros volumes de données !

Bonjour,

Salut U.Milité

Une proposition quasi identique à celle d'U.Milité ... ( à part le rang k ...)

Un grand merci à U.Milité et à James007.

Ça marche du feu de Dieu, j'ai transposé la formule dans mon fichier initial et c'est mieux que parfait !!!

Merci encore

@+

Nous sommes sensibles à tes remerciements très chaleureux ..

Rechercher des sujets similaires à "recuperer donnees doublons"