Publipostage et format date

Bonjour,

Je me sers d'un tableur EXCEL comme base de données mais dans le word, ... je ne retrouve pas la date dans le format jj/mm/aaaa !

Curieusement, la première date est dans le bon format mais pas les suivantes... Est-ce que cela est dû à ce que les autres dates soient créées par une formule ?

J'ai lu qu'il fallait rajouter " @ dd/MM/yyyy"... mais sans succès.

Est-ce qu'il existe une astuce au niveau d'Excel ou dans word ?

Excellente journée

bonjour

en fait \@ dd/MM/yyyy

avec le \

dans la bonne case

(cliquer sur <Code de champ> ou <Masquer les codes> pour afficher la longue ligne)

voir

https://clic-en-berry.com/comment-changer-le-format-date-dans-une-fusion-word/

bonjour

en fait \@ dd/MM/yyyy

avec le \

dans la bonne case

(cliquer sur <Code de champ> ou <Masquer les codes> pour afficher la longue ligne)

Je viens de réessayer.... cf nouvelles pièces jointes en rajoutant le \@ dd/MM/yyyy

sans succès

Où est mon erreur ?

Je n'ai pas trouvé le code de champ mais j'ai suivi la procédure indiquée dans le lien, ce qui apparemment revient au même

peut-être les espaces dans le machin \@

peut-être les espaces dans le machin \@

Je viens d'essayer .... sans succès.

Cela doit être "tout simple" mais il faut connaître le truc !

Je reste preneur d'une solution ou d'une astuce pour contourner cette difficulté.

Bonjour

Tu fais ALT F9 pour voir le code de champ et tu tapes dans les accolades juste derrière nom du champ

{MERGEFIELD date_1\@ dd/MM/yyyy}

re

j'ai réussi à afficher

jj/05/aa

au lieu de 05/01/2018

ya du progrès

j'ai recréé une base Access, même problème

solution brutale et qui marche :

dans Excel, mettre

'16/01/2018

l'apostrophe met en texte

du coup plus de problème de format

edit salut Chris

on voit bien le format maj+F9 (ne pas oublier de faire F9 pour être certain qu'il recalcule) mais ça ne change rien

solution brutale et qui marche :

dans Excel, mettre

'16/01/2018

l'apostrophe met en texte

du coup plus de problème de format

Effectivement, cela marche super bien mais cela ne peut rester qu'en dépannage =

en effet, j'ai

- la première colonne = j'ai la date du premier du mois

par saisie manuelle en ligne 1

puis par FIN.MOIS +1pour la ligne 2 et suivantes

  • la seconde colonne = j'ai la date via = FIN.MOIS
  • la troisième colonne = date du premier mois + 15

Ce qui fait des dizaines de dates et c'est pénible de rajouter à chaque foi un ' pour avoir du texte.

Il doit y avoir une solution pour simple.... faut-il encore la trouver !

re

on peut faire une formule pour passer de la date en texte

il faut ruser et passer par des concaténations de JOUR() / MOIS() / ANNEE() le tout en texte

Bonjour

J'ai testé sur Word 2010 FR le fichier de Tonthon et cela marche parfaitement avec

{MERGEFIELD date_1\@ dd/MM/yyyy}

mais n'ai eu aucun retour de Tonthon...

Bonjour

J'ai testé sur Word 2010 FR le fichier de Tonthon et cela marche parfaitement avec

{MERGEFIELD date_1\@ dd/MM/yyyy}

mais n'ai eu aucun retour de Tonthon...

Bonjour 78chris

J'aimerais bien comprendre pourquoi cela marche chez toi et pas chez moi alors que nous avons apparemment tous les 2, la version Word 2010.

Pourrais-tu m'envoyer le fichier où cela fonctionne bien, cela me permettrait peut-être de voir des paramètres d'options différentes ?

En l'état, je ne vois que cela mais si tu as d'autres pistes, je suis preneur

Excellente journée

RE

Ne pas oublier de tout sélectionner CTRL A puis F9

Il faudra refaire le lien vers le fichier Excel, le chemin est en dur dans Word

publipost
17publipostage.docx (22.18 Ko)

re

yapa les " " dans ton format !

c'est la différence !

arf !

en plus je viens de réessayer mon fichier à moi

sans aucune mise en forme, ça marche

c'est incompréhensible

Re,

J'aime bien comprendre néanmoins je vais laisser passer quelques nuits avant de m'y remettre car là, je tourne en rond !

En attendant, profitons des bons moments.

Rechercher des sujets similaires à "publipostage format date"