Nombre de fois jour date dans colonne

3essai.xlsx (10.51 Ko)

bonjour à tous !

j'ai dans la colonne A les dates ( jour date mois années)

via une formule, je serai intéressé d'avoir dans la colonne C1 combien il y a de lundi, C2 combien de mardi,C3 combien de mercredi jusqu'à dimanche.

merci de votre réponse.

Bonjour Benoist

En C1, mettre la formule

=SOMMEPROD((JOURSEM(A$1:A$31;2)=LIGNE())*1)

A recopier vers le bas

Explications :

JOURSEM(A$1:A$31;2)

Donne 1 pour lundi, 2 pour mardi, etc...

LIGNE()

Donne le numéro de ligne ou se trouve la formule

SOMMEPROD()

Fait le produit matriciel de la formule à l'intérieur

A+

re

j'ai du me tromper ( jeudi, vendredi, samedi, dimanche )

ça me marque #NOMBRE!

2essai.xlsx (10.99 Ko)

Bonjour Besnoist,

Je ne sais pas si ça passe en Excel 2007

J'utilise la fonction

=SOMME(--(JOURSEM($A$1:$A$31;11)=1))

Joursem()=1 retourne une matrice de VRAI pour les lundis et de faux pour les autres jours, le -- convertit en numérique les VRAI et les faux

1essai-1.xlsx (11.77 Ko)

et le somme te renvoie un scalaire.

merci de la réponse,

j'ai appliqué la formule sur mon fichier

sauf que le samedi ça me met 45 samedi alors qu'il y en a 32

3essai-3.xlsx (12.94 Ko)

Bonsoir à tous !

La formule retourne la valeur 1 quand la cellule est vide.

Insérez un tableau structuré et utilisez la colonne ('ex "colonne 1") dans la formule de manière à n'opérer que sur les cellules concernées.

Bonjour à tous,
Une proposition.
Cdlt.

capture d ecran 2023 06 27 204937

j'ai mit pareil en formule,

mais j'ai pas la même chose !

4essai-3.xlsx (20.00 Ko)

Bonsoir,

Je continue avec mon SOMMEPROD()

=SOMMEPROD((JOURSEM(A$1:A$200;2)=C1)*(A$1:A$200<>""))

Ce qui donne

image

A+

Bonjour,
Oups !
Excel 2007

Bonjour,

merci à tous, et surtout à Bruno M45 pour la bonne réponse en se qui me concerne

Cordialement.

Rechercher des sujets similaires à "nombre fois jour date colonne"