Mise en forme numéro de téléphones

Bonjour,

J'ai une liste de numéros dans une colonne au format xx.xx.xx.xx.xx ou xxxxxxxxx.

J'aimerais les transformer au format 33xxxxxxxxx ou +33xxxxxxxxx

Je n'arrive pas à trouver la formule correspondante à ce que je souhaite.

Quelqu'un peut m'aider ?

Merci

8exemple.xlsx (8.67 Ko)

Bonjour Jean Michel,

Tu va sur la cellule ou la plage de cellule ayant ton numéro de téléphone et dans l'onglet format, du clique dans le petit coin à droite :

tel

Une fenêtre s'ouvre, et à gauche du clique sur "spécial" puis sur "Numéro de téléphone" :

tel2

Tu valide ensuite ton choix de format !

Voilà Restant à dispo

Bonjour jeanmichel0404,

Je ne sais pas si c'est vraiment ce que tu recherches, mais sans passer par une formule, tu fais un CTRL+F sur la plage voulue pour remplacer le "." par rien, pour modifier le format des numéro "xx.xx.xx.xx.xx" puis, tu crées un format personnalisé "+33"0000000000 pour avoir à la fin le format désiré.

Cordialement,

IB

Bonjour,

Deux malheureux petits exemples ne permettent pas de vérifier l'existence de cas particuliers ... une première proposition à tester:

="+33"&TEXTE(SUBSTITUE(A1;".";"");"000000000")

On aurait aussi pu utiliser un format personnalisé, en supprimant les '.'

[Edit:] salut Juice, IronBoule ... et Jean-Éric

Bonjour,

A tester :

=SI(ESTNUM(A1);TEXTE(A1;"+33#########");TEXTE(SUBSTITUE(A1;".";"");"+33#########"))

J'ai trouvé finalement

Selection de la colonne avec tous les numéros

CTRL+H

Remplacer le . par rien

et formule =CNUM(CONCATENER(33;A1))

Merci

Rechercher des sujets similaires à "mise forme numero telephones"