Méthode et technique de calcul

Bonjour,

Suite à un travail de mettre à jour une base de donnée, je cherche à connaître un pourcentage,qui montre la différence positive ou négative face à une pièce théorique.

Pour être plus clair voir la feuille excel:

colonne B à Y valeur relevé dit pratique

colonne Z et AA valeur théorique

Colonne AB à AQ résultante

Valeur NA, pas de mesures

Les calculs sont simples

en 1er c'est une moyenne numérique et en second c'est un pourcentage (produit en croix).

Mon problème étant que des données ne sont pas relevé et cela fausse le résultat . Je ne sais pas comment comment calculer mes moyennes avec les NA aléatoires.

Merci de votre aide

ciao

90valeur-mesure.xlsx (40.38 Ko)

Je ne pense pas avoir compris ta question:

Les NA n'influent pas dans les calculs de moyennes puisqu'ils ne sont pas des valeurs numériques. De plus les cases vides non plus.

Si tu cherches à savoir combien de NA tu as dans la colonne B il suffit de faire

=NB.SI(B4:B115;"=NA")

En fait le problème et qu'il bloque mon calcul, c'est là le coeur de ma question

Pour exemple

Calcul moyenne

=(B12+E12)/2

Si E12 correspond à NA le calcul et faussé,de plus la division ne fonctionne plus.

Alors je voulait savoir comment passer outre NA.

j'ai un autre calcul ou j'ai 4 entités

=(O9+P9+R9+S9)/4, si R9 et S9 sont NA je vous laisse deviner ce qu'il se passe.

moi je voudrait dans ce cas là faire =(O9+P9+NA+NA)/2

En espérant avoir été plus clair

=MOYENNE(O9;P9;R9;S9)

Purée franchement à force de vouloir compliqué la chose j'ai oublié cette formule.

Désolé pour le dérangement

Merci

Rechercher des sujets similaires à "methode technique calcul"