Macro

bonjour, je voudrais faire le traitement suivant avec une macro mais je suis nul en VB et se travail est tres urgent ,

si (A2::A1000="NCR") et si (B2:B1000="ABR") et si (mois(O2:O1000)=mois(X1)) ALORS il calcul le nombre de A2:A1000

ca serait vraiment genial si je pourrais avoir une reponse...merci a vous tous

Bonsoir,

Tu veux une macro pourquoi faire ?

faudrait voir la feuille

la formule

=SOMMEPROD(($A$2:$A$1000="NCR")*($B$2:$B$1000="ABR")*(MOIS($O$2:$O$1000)=MOIS($X$1)))

Amicalement

Claude

ca marche,merci

Bonsoir,

En VBA, çà donnerait

Sub Formule()
Dim Lg&
    Lg = Range("a" & Rows.Count).End(xlUp).Row
    Range("c1") = _
    "=SUMPRODUCT((a2:a" & Lg & "=""NCR"")*(b2:b" & Lg & "=""ABR"")*(MONTH(o2:o" & Lg & ")=MONTH($x$1)))"
End Sub

la plage étant ici actualisée avec la dernière ligne en colonne "A"

Claude

2j-sparo-macro.zip (13.11 Ko)
Rechercher des sujets similaires à "macro"