Lister joueurs dont le score = 0

Bonjour,

En A2 le nom des joueurs.

En B2 les scores (qui peuvent être négatifs)

en D2 je voudrais connaître la méthode pour lister les joueurs dont le score = 0.

fichier en pièce jointe

merci pour votre aide

20joueurs.zip (4.54 Ko)

Bonjour,

Une tentative avec une formule matricielle en D2 :

=SI(LIGNES($1:1)>NB.SI($B$2:$B$11;0);"";INDEX($A$1:$A$11;PETITE.VALEUR(SI($B$2:$B$11=0;($B$2:$B$11=0)*LIGNE($B$2:$B$11));LIGNES($1:1))))

Formule matricielle à valider par CTRL + MAJ + ENTREE

à recopier vers le bas

@+

Bonjour à tous,

Tu peux aussi utiliser un filtre

Sub Filtre()
    Range("a1:b" & [a65000].End(xlUp).Row).AdvancedFilter Action:=xlFilterCopy, CriteriaRange:= _
    Range("j1:j2"), CopyToRange:=Range("d2"), Unique:=False
End Sub

Amicalement

Claude

Bonsoir,

Merci à vous deux.

Les deux méthodes fonctionnent parfaitement.

Je voulais éviter le filtre et je cherchais cette fameuse formule matricielle.

encore merci à vous

Rechercher des sujets similaires à "lister joueurs score"