Formule et VBA: compter espaces d'une chaine

Bonsoir à tous,

Tout est dans le titre, j'ai un trou de mémoire,

Compter le nombre d'espaces dans une cellule

1) par formule

2) par code VBA

merci de votre aide

Amicalement

Claude

Bonsoir Claude ,

Une solution par formule:

=NBCAR(A1)- NBCAR(SUBSTITUE(A1;" ";""))

Avec le VBA , je ne sais pas (comme tout ce qui est VBA ...)

Amicalement

Salut le forum

Pour compter le nombre d'espace (Formule)

=SOMME(NBCAR(Plage)-NBCAR(SUBSTITUE(Plage;" ";"")))

Pour compter le nombre d'espace (VBA)

For i = 1 To Len(Range("B2"))

If Mid(Range("B2"), i, 1) = " " Then Compteur = Compteur + 1

Next i

MsgBox ("Cette phrase contient " & Compteur & " espaces.")

Mytå

Merci à vous deux,

Mytå,

Le but de ma question était de pouvoir déterminer un "Split"

Je ne suis pas sur de bien utiliser cette fonction

Sub Separe()
Dim Lg%, i%, J As Byte, Ct, x
    Application.ScreenUpdating = False
    Lg = Range("A65536").End(xlUp).Row
    Application.CutCopyMode = False
    Cells(1, 2).EntireColumn.Insert
    Cells(1, 2) = "Prénom"
        For i = 2 To Lg
            Cells(i, 1).Value = Trim(Cells(i, 1).Value) 'suppr espaces début/fin
            Ct = 0
            For J = 1 To Len(Cells(i, 1)) 'merci Mytå
                If Mid(Cells(i, 1), J, 1) = " " Then Ct = Ct + 1
            Next J

            x = Split(Cells(i, 1))
            Cells(i, 2) = x(0)
            Cells(i, 1) = x(Ct) 'Ct = nombre espaces
        Next i
    Columns("a:b").AutoFit
End Sub

çà marche mais était-ce bien la bonne méthode, ton avis ?

Amicalement

Claude

54deconcat2.zip (13.81 Ko)

Re le forum

Claude, pas besoin du compteur, tu supprimes déja les espaces de début et de fin

Sub Separe()
Dim I As Long, X

Cells(1, 2).EntireColumn.Insert
Cells(1, 2) = "Prénom"
    For I = 2 To Range("A65536").End(xlUp).Row
      X = Split(Trim(Cells(I, 1)))
        Cells(I, 2) = X(0)
        Cells(I, 1) = X(UBound(X))
    Next I
Columns("a:b").AutoFit

End Sub

Mytå

re,

Alors là, nickel !

merci Mytå,

tu m'as encore appris quelque chose aujourd'hui

à+....Claude

Re

Au plaisir de se retrouver sur d'autres ficelles

Mytå

Rechercher des sujets similaires à "formule vba compter espaces chaine"