Formule Date et heure

Bonsoir à tous,

Pour notre ami "emeuh" et donner suite à ce poste

https://forum.excel-pratique.com/excel/insertion-automatique-de-lignes-pas-de-temps-t23368.html

Il faudrait convertir un texte de 14 caractères (représentant une date + heure, minutes, seconde)

en une date au format du genre Maintenant()

Exemple de donnée qui correspond à 01/09/2009 5:30

20090901053000

J'arrive à sortir la date, mais il faudrait aussi les heures et minutes

voir fichier

c'est jouable ?

Amicalement

Claude

14question-date.zip (8.83 Ko)

Salut Claude,

Une solution (à mettre en C10) :

=(DATEVAL(STXT(B10;7;2)& "/" & STXT(B10;5;2) & "/" & GAUCHE(B10;4))+TEMPSVAL(STXT(B10;9;2)&":"&STXT(B10;11;2)&":"&STXT(B10;13;2)))*1

On extrait la date, on extrait l'heure, on fait la somme des deux et on multiplie le tout par 1 pour que ça donne une valeur. Ensuite on met la cellule au format personnalisé suivant par exemple :

jj/mm/aaaa hh:mm:ss

merci vba-new,

Je regarde demain matin, si je vais pouvoir exploiter ces résultats,

pas sûr sans DATEDIF !

bonne nuit

Claude

Bonjour,

Un essai avec cette formule :

=TEXTE(A1*1;"0000""-""00""-""00"" ""00"":""00"":""00")*1

à mettre au format jj/mm/aaaa hh:mm:ss

@+

Bonjour vba-new, thibo, forum,

Vos 2 formules fonctionnent parfaitement et j'ai pu les exploiter.

thibo,

dans ta formule, comment se fait le distingo entre le jour et le mois ?

les résultats sembles bons, mais je ne vois pas ce qui empêche l'inversion "jj" et "mm"

Ci-joint, ce que çà donne avec la formule de thibo (+ courte)

merci à vous

Amicalement

Claude

11emeuh-insert-2.xlsm (42.56 Ko)

Bonjour,

dubois a écrit :

... comment se fait le distingo entre le jour et le mois ? ...

Euh... bonne question...

Il semble que la reconnaissance des dates se fasse sur les formats aaaammjj ou jjmmaaaa ou jjmmaa.

Pour un format autre, il faudra se reporter sur une formule telle que celle proposée par vba_new

@+

Bonjour à tous,

En somme, c'est un coup de pot que çà marche ici,

la formule de vbe-new serait donc plus sûre.

La macro a les 2 formules, suffira d'activer la bonne

merci et bonne journée

Claude

Rechercher des sujets similaires à "formule date heure"