Formule avec OU / ET

Bonjour,

J'ai besoin de votre aide sur une formule que je n'arrive pas à construire. C'est une prime à calculer avec des OU et des ET :

Si objectif et/ou réalisation < 2000€ et R/O à 90% = 150€

Si objectif et/ou réalisation < 2000€ et R/O à 100% = 350€

Si objectif et/ou réalisation < 2000€ et R/O à 105% = 550€

Si objectif et/ou réalisation >=2000€ et <4000€ et R/O à 90% = 250€

Si objectif et/ou réalisation >=2000€ et <4000€ et R/O à 100% = 450€

Si objectif et/ou réalisation >=2000€ et <4000€ et R/O à 105% = 650€

Si objectif et/ou réalisation >= 4000€ et R/O à 90% = 350€

Si objectif et/ou réalisation >= 4000€ et R/O à 100% = 550€

Si objectif et/ou réalisation >= 4000€ et R/O à 105% = 750€

Help

Un grand merci par avance.

3classeur1.xlsx (10.87 Ko)

Bonjour,

Si objectif et/ou réalisation ==> Ça ne veut rien dire

c'est l'un pas l'autre, c'est le max des deux ou le min etc ...

2astragale.xlsx (12.68 Ko)

Crdlmt

Bonjour,

à voir si cela correspond à ta demande.

Formule en E2 et à tirer vers le bas

=SI(ET(OU(B2<2000;C2<2000);ET(D2>=90%;D2<100%));150;SI(ET(OU(B2<2000;C2<2000);ET(D2>=100%;D2<105%));350;SI(ET(OU(B2<2000;C2<2000);D2>105%);550;SI(ET(OU(ET(B2>=2000;B2<4000);ET(C2>=2000;C2<4000));ET(D2>=90%;D2<100%));250;SI(ET(OU(ET(B2>=2000;B2<4000);ET(C2>=2000;C2<4000));ET(D2>=100%;D2<105%));450;SI(ET(OU(ET(B2>=2000;B2<4000);ET(C2>=2000;C2<4000));D2>105%);650;SI(ET(OU(B2>=4000;C2>=4000);ET(D2>=90%;D2<100%));350;SI(ET(OU(B2>=4000;C2>=4000);ET(D2>=100%;D2<105%));550;SI(ET(OU(B2>=4000;C2>=4000);D2>105%);750;0)))))))))

Cordialement

Merci Ednoork pour cette loooongue formule qui semble marcher.

Je vais la tester sur mon "vrai" fichier, j'attendrai demain pour clore le fil si tout est ok, sinon je reviendrai poser une question.

DjiDji59430 : j'ai repris le texte exact donné par mon responsable... pour lui ça veut surement dire quelque chose

Bonne fin de journée.

Et pas de nouvelle de ma solution ??

Ah pardon ! Je n'avais lu que ta réponse et pas le fichier envoyé. Je vais tester demain avec mon vrai fichier de primes et je viendrai te dire.

Merci beaucoup pour la dispo

Re,

Je viens clore le fil et vous remercier, les 2 propositions fonctionnent très bien.

Me voici sauvée !

Bonne journée

Rechercher des sujets similaires à "formule"