Formule à plusieurs conditions

Bonjour à tous,

J'ai encore besoin de vous, Excel n'est pas mon ami

Je n'arrive pas à combiner plusieurs critères dans une formule,

je m’explique, sur la première feuille, je voudrais appliquer une formule à la colonne H, par exemple en ligne 21( dates de début de formation) correspondent elle même à un nombre de jour (ligne 8) de la colonne Q à AB.

Donc si possible : si "O" en colonne M, ne calculer que les jours de formations associées aux dates en les additionnant sinon rien. J'ai tente plusieurs formules mais je dois être encore trop novice :-(

=SI(NBVAL("");Q8=3;""+SI(NBVAL(R9);R8;SI(NBVAL(S9);S8+SI(NBVAL(T9);T8+SI(NBVAL(U9);U8+SI(NBVAL(V9);V8+SI(NBVAL(W9);W8+SI(NBVAL(X9);X8+SI(NBVAL(Y9);Y8+SI(NBVAL(Z9);Z8+SI(NBVAL(AA9);AA8+SI(NBVAL(AB9);AB8;""))))))))))))

=SI(Q9>0;Q8)+SI(R9>0;R8)+SI(S9>0;S8)+SI(T9>0;T8)+SI(U9>0;U8)+SI(V9>0;V8)+SI(W9>0;W8)+SI(X9>0;X8)+SI(Y9>0;Y8)+SI(Z9>0;AA9)+SI(AB9>0;AB8)

et encore bien d autres infructueuses

Merci pour votre aide

6essai.xlsx (120.47 Ko)

Bonjour Milly1234,

Pourquoi ne pas essayer tout simplement

=SI(M21="O";NBVAL(Q21:BA21);0)

@+

Bonjour,

Merci pour l'aide, en effet ça me mets bien le nombre de formation réalisées, mais ma difficulté est d y associer le nombre de jours (Q8 à AB8)

Re,

Sur la ligne 21, il y a bien 3 jours de formation non !?

Edit : ok je pense avoir compris, le nombre de jours de formation est en ligne 8

Alors, il faut

=SI(M21="O";SOMME.SI(Q21:BA21;"<>";Q8:BA8);0)

@+

Je desepère :-(

ca fonctionne sur la ligne 21 mais pas sur les autres

Mais pourquoiiiiiiiiii

=SI(M21="O";SOMME.SI(Q21:AB21;"<>";Q8:Q8);0);SI(N21="O";SOMME.SI(AD21:AI21;"<>";AD8:AI8);0);SI(O21="O";SOMME.SI(AK21:AQ21;"<>";AK8:AQ8);0)

j'ai modifié mais ca n y change rien

=SI(M21="O";SOMME.SI(Q21:AB21;"<>";Q8:AB8);0);SI(N21="O";SOMME.SI(AD21:AI21;"<>";AD8:AI8);0);SI(O21="O";SOMME.SI(AK21:AQ21;"<>";AK8:AQ8);0)

Re,

Désolé, il faut figer la ligne (avec des $) du nombre de jour de formations,, j'ai zappé

=SI(M21="O";SOMME.SI(Q21:BA21;"<>";Q$8:BA$8);0)

@+

Faut pas être désolé, vous m'aidez déjà beaucoup ;-)

Cela fonctionne pour la ligne 21 seul mais quand j imbrique les formules ça passe plus, je vais pas en dormir lol

=SI(M21="O";SOMME.SI(Q21:AB21;"<>";Q$8:AB$8);0);SI(N21="O";SOMME.SI(AD21:AI21;"<>";AD$8:AI$8);0);=SI(O21="O";SOMME.SI(AK21:AQ21;"<>";AK$8:AQ$8);0)

Re,

Pour imbriquer des conditions, il ne faut pas fermer le SI() seulement à la fin, sinon Excel vous met un message d'erreur

Voici la formule corrigée

=SI(M21="O";SOMME.SI(Q21:AB21;"<>";Q$8:AB$8);SI(N21="O";SOMME.SI(AD21:AI21;"<>";AD$8:AI$8);SI(O21="O";SOMME.SI(AK21:AQ21;"<>";AK$8:AQ$8);0)))

@+

3essai1.xlsx (14.50 Ko)

C'est bien ce que je dis je ne vais pas en dormir lol

Au secoursssssssssssssssssss

Re,

Je pense que là, vous exagérez un petit peu

Mettez-vous en C4, appuyez sur F2 et regardez les cellules en couleurs !!!

Bonne soirée,

Désolée, je crois que ça fait trop longtemps que j y suis ... Je retente demain

Encore merci et excusez moi c'est vraiment pas de la mauvaise volonté, la logique excel et moi c'est pas ca !!

Encore mille merci pour votre aide :-)

Effectivement j'avais coller la formule de la ligne 21 sur la ligne 9 et j essayer de tirer ma formule !

quelle quiche !!!

Merciiiiiiii

Bonjour

Comme quoi il faut savoir parfois ne pas insister

Une bonne nuit de sommeil et hop c a repart

Rechercher des sujets similaires à "formule conditions"