Formule

Bonjour,

J'ai besoin de votre aide.

j'ai deux numéro compris entre 0 et 99. il faudrait que je puisse combiner ses deux numéros de la façon suivante :

je veux créer de nouveaux numéros en combinant les deux dizaines ensemble, les deux unités ensemble, la dizaine de l'un et l'unité de l'autre,....

j'ai créer un fichier avec un exemple dedans : 26 13 et sur la même ligne les numéros que je dois obtenir.

juste une chose il faut que ce soit bien des numéros car derrière il va y avoir des calculs dessus.

à l'avance un grand merci.

3essai.xlsm (14.44 Ko)

Bonjour Danval,

Est-ce que tu as essayé avec les fonctions Gauche et Droite. A priori, nul besoin de vba ?

Cdt

Bonjour,

oui mais je n'y arrive pas.

pas besoin de VBA si on peut le faire simplement avec des formules dans les cases.

Je viens de faire l'essai.

Cdt

9retour-essai.xlsx (13.63 Ko)

Bonjour à tous,

et pour convertir en numérique la proposition de ddetp88 :

=--(GAUCHE(A1;1) & DROITE(B1;1))

eric

Bonjour,

Yes cela me parait très bien juste une erreur car quand le numéro est un chiffre il faut le prendre en compte et considérer que le gauche est 0.

exemple 5 23 et bien il faut utiliser 05 23

merci pour l'avancement trop bien

Re,

Amuse toi, voici un exemple pour la cellule D1:

=SI($A1<10;0& DROITE(B1;1);GAUCHE(A1;1) & DROITE(B1;1))

Cdt

Bonjour,

Merci pour la solution.

Rechercher des sujets similaires à "formule"