Fonction Si pour calcul des salaires

Bonjour,

Je dois appliquer la fonction Si qui permet le traitement de la condition suivante:

Si l'employé travaille plus de 40hrs, le nombre d'heure en surplus est payé à temps et demi (1,5) sinon l'employé est payé à son taux normal.

Voici ma formule: =SI(D12<=40;C12*D12;SI(D12>=40;C12*D12;1*1,5*C12))

Ça fonctionne si l'employé ne fait pas du temps supplémentaire, je ne trouve pas comment écrire pour les heures supplémentaire à 40.....

J'attends de vos nouvelles.

Merci beaucoup

Bonjour,

Essaye avec :

=SI(D12<=40;C12*D12;1,5*C12*D12) 

En vertu du principe que si c'est pas inférieur à 40, c'est que ... c'est supérieur à 40

Cela dit, il faudrait que tu donnes plus de détails sur le contenu de tes cellules C12 et D12

@+

Bonjour, Salut thibo,

Essaye la formule suivante :

=(D12*C12)+(D12>40)*(D12-40)*(C12*1,5)

J'ai essayé et ça fonctione malheureusement pas...

C D E

Taux Temps Salaire brut

($/hres) (hres) ($)

17,00 38 646

14,00 40 560

10,00 41 615 La réponse est 415

9,75 40 390

8,50 39,5 335,75

8,50 40,5 516,375 La réponse est 346,38 et non 516....

7,00 40 280

Voici mon tableau et mon C12 = 17 (taux horaire) et D12 = 38 (nombre d'heure par sem)

Je dois calculer le salaire brut... Dans ce tableau avec les deux formules, la première la mienne et l'autre de Thibo ça fonctionne pour le temps régulier. Dès que c'est en haut de 40 ça ne fonctione plus

P/S; Eh oui c'est un travail d'école... Merci encore de m'aider à comprendre pour mon examen de lundi... Désolé pour les espaces manquants...

thibo a écrit :

Bonjour,

Essaye avec :

=SI(D12<=40;C12*D12;1,5*C12*D12) 

En vertu du principe que si c'est pas inférieur à 40, c'est que ... c'est supérieur à 40

Cela dit, il faudrait que tu donnes plus de détails sur le contenu de tes cellules C12 et D12

@+

Allô raja,

Désolé ça fonctionne pas plus.... Mais j'ai réécrit autre chose qui peut plus t'aider à m'aider!!!

Raja a écrit :

Bonjour, Salut thibo,

Essaye la formule suivante :

=(D12*C12)+(D12>40)*(D12-40)*(C12*1,5)

re,

Pourrais-tu nous joindre un extrait de ton fichier plutôt qu'une description de celui-ci ?

Ca nous éviterait de devoir le reconstituer

Pour joindre un fichier, voir le lien bleu en haut Joindre un fichier

A te (re)lire

@+

https://www.excel-pratique.com/~files/doc/Salaire_Marie_Pier_Lacombe.xlsx

Voici mon fichier, désolé je suis pas tellement habituée sur les forums...

Merci encore

Re,

Merci d'enregistrer ton fichier au format .xls et de nous retourner pour que tout le monde puisse accéder.

https://www.excel-pratique.com/~files/doc/Salaire_Marie_Pier_Lacombe.xls

Voici en format 97-2003.

Raja a écrit :

Re,

Merci d'enregistrer ton fichier au format .xls et de nous retourner pour que tout le monde puisse accéder.

Re,

Pour moi, la formule que j'ai préconisée marche bien. Essaye de calculer manuellement et comparer. A moins que je n'ai pas compris la règle de calcul. Donne-nous un exemple de calcul manuel détaillé pour comparer.

PS : quand je calcule manuellement, je ne retrouve pas les mêmes montants que tu as donnés dans un précédent message.

Genre D14 taux horaire 10$/heure il a travaille 41.

Le calcul à la main est 10 x 40 + 1 x 15 = 415$ C'est un calcule comme ça pour ceux qui travaille plus de 40hrs. Au exemple D17 taux horaire 8,50 il a travaillé 40,5 hrs

8,50 x 40 + 12,75 x ,5hrs = 346,38

Espérons que tu comprendras!

Raja a écrit :

Re,

Pour moi, la formule que j'ai préconisée marche bien. Essaye de calculer manuellement et comparer. A moins que je n'ai pas compris la règle de calcul. Donne-nous un exemple de calcul manuel détaillé pour comparer.

PS : quand je calcule manuellement, je ne retrouve pas les mêmes montants que tu as donnés dans un précédent message.

Re,

Oups une erreur de synthèse,

Essaye alors la formule suivante en E12 et recopie vers le bas :

=(D12*C12)+(D12>40)*(D12-40)*(C12*0,5)

Raja!!!!! Mille merci!!!! Je vais continuer mon devoir espérons que ça va aller mieux avec la recherche V...

Merci encore une fois!

Raja a écrit :

Re,

Oups une erreur de synthèse,

Essaye alors la formule suivante en E12 et recopie vers le bas :

=(D12*C12)+(D12>40)*(D12-40)*(C12*0,5)
exemple
2exemple.xlsx (21.02 Ko)
Rechercher des sujets similaires à "fonction calcul salaires"