Fonction recherche ou macro ?

Bonjour,

je bloque sur la fonction recherche, je voudrais que si on retrouve les numéros des lignes J,K,L,M dans la sélection A,B,C,D,E,F,G que la date apparaisse en N.

faut 'il passer par une macro ?

je mets un exemple à disposition.

merci d'avance pour l'aide que vous m'apporterez

14exemple.xlsm (8.55 Ko)

Bonjour,

En passant par une colonne intermédiaire, on peut déjà savoir le nombre de lignes qui répondent aux critères :

Formule en I1 : =CONCATENER(",";A1;",";B1;",";C1;",";D1;",";E1;",";F1;",";G1;",")

Formule en P2 : =NB.SI($I:$I;"*,"&J2&"*,"&K2&"*,"&L2&"*,"&M2&"*")

Pour la 1ère date :

Formule en N2 : =INDEX($H$1:$H$9;EQUIV("*,"&J2&"*,"&K2&"*,"&L2&"*,"&M2&"*";$I$1:$I$9;0))

S'il y a plusieurs résultats possibles, on peut utiliser une variante de la dernière fonction qui utilise DECALER pour commencer la plage de recherche (et de résultat) après la première occurrence trouvée. Ca se corse s'il y a plus de 2 résultats...

d'accord, merci je vais tester

Bonsoir,

ça fonctionne mais avec des erreurs, comment ça se fait que la même formule puisse générer des erreur ?

1-2 trouver 12 fois alors que le résulta attendu été 0 même la date n'est pas bonne.

merci pour votre aide

114151626303107/05/2021,1,14,15,16,26,30,31,1207/05/2021FAUX
12
16102022252604/05/2021,1,6,10,20,22,25,26,
1307/05/2021FAUX
4
1312523272803/05/2021,1,3,12,5,23,27,28,
1402/05/2021VRAI
1
271014323402/05/2021,2,7,10,1,4,32,34,
1503/05/2021VRAI
1
310142022262801/05/2021,3,10,14,20,22,26,28,
1604/05/2021VRAI
1
1exemple.xlsm (10.35 Ko)

Bonjour à tous les deux. Une proposition avec une macro :

8exemple.xlsm (18.90 Ko)
merci, je vais tester :)
Rechercher des sujets similaires à "fonction recherche macro"