Fonction Index + equiv + decaler

Bonjour a tous,

J'ai besoin du coup de main des experts excel. J'ai cherche mais en vain.

Voici mon fichier de travail.

39excel.xlsx (13.26 Ko)

Il s'agit d'affecter un coefficient de productivite dans un planning selon la duree de la tache.

Il faut bien sur que le debut de la tache se reporte sur le planning.

J'arrive a faire demarrer la tache dans la bonne colonne. Par exemple la premiere tache va demarrer en Avril 2016 grace a la fonction SI + ET.

Je souhaite ensuite me referrer au tableau donnant les ratios de productivite selon la duree de la tache.

J'arrive a determiner facilement la ligne par contre je galere a definir la colonne qui doit etre '1' lorsque la tache commence dans le planning, puis se decaler vers la droite de 1, lorsque j'etends ma formule.

J'ai indique en jaune fluo les donnees que je souhaiterai obtenir.

Merci par avance pour votre aide....

=IF(AND(F$4>=$B7,F$4<=$A7),INDEX($AH$401:$BD$415,MATCH($AF7,$AF$401:$AF$415,0),XXXXXXXXXX),"")

Bonjour,

proposition de formule à mettre en F7 et à tirer vers la droite et vers le bas.

=SI(OU(F$4<$C7;$C7>F$4);"";INDEX($E$18:$N$32;EQUIV($D7;$C$18:$C$32);EQUIV(ENT((F$4-$C7)/30)+1;$E$17:$N$17;0)))

ou

=IF(OR(F$4<$C7,$C7>F$4),"",INDEX($E$18:$N$32,MATCH($D7,$C$18:$C$32),MATCH(INT((F$4-$C7)/30)+1,$E$17:$N$17,0)))

Wahou, bilingue !!

Au top!! Merci beaucoup...!!

Rechercher des sujets similaires à "fonction index equiv decaler"