Fonction Excel qui compte des données à la suite

Bonjour le forum,

Je fais appel aux experts, aux néophytes et aux autres afin de solutionner mon problème.

J'ai beau avoir retourné le problème dans tous les sens, je n'ai pas trouvé, je cherche une réponse, à savoir déjà si ma demande est réalisable.

Ci-joint un fichier contenant toutes les infos.

Je souhaite n'utiliser que des formules excel, sans passer par VBA)

Encore merci.

25probleme.zip (7.19 Ko)

ps : cette demande ne fait pas doublon avec une autre que j'ai postée récemment. Elle résulte des réponses reçues à mon précédent post.

Bien cordialement

Bonjour

Essaie en B26, incrémenté vers le bas, et regarde si cela convient

=SI(ET(A1<>A2;NB.SI($A$2:$A2;$A2)>1);SOMMEPROD(N(DECALER($A$2;LIGNES($A$2:$A2)-2;):$A2=$A2));SOMMEPROD(N($A$2:$A2=$A2)))

Cordialement

Edit Non, marche pas en augmentant le tableau!! Il faut retourner au charbon, mais je pense que l'idée devrait aboutir

Merci de t'être penché sur mon problème. Comme tu l'as dit, un problème se pose.

Quand je saisis T1 T6 T1 T3 T1, un problème se pose aussi. Dès qu'il y a 2 fois la variable ça bloque.

Bonjour

Celle-ci semble fonctionner, teste là plus avant (saisie matricielle)

Cordialement

13probleme.zip (9.25 Ko)

Ca plante, ou alors je m'y suis mal pris ?

12probleme-1.zip (7.26 Ko)

Re, bonjour

Bien sur, tu as pris la mauvaise.

Ton fichier avec la seconde que j'ai donnée.

Cordialement

30probleme-1.zip (8.21 Ko)

Grand merci. C'est génial

Rechercher des sujets similaires à "fonction qui compte donnees suite"