Figer valeur du mois précédent

Bonjour, le forum

Dans le tableau jaune, des valeurs (de 0 à 10) rentrées chaque mois.

J'aimerai que dans le tableau orange, les valeurs entrées le mois précédent restent.

Par exemple en séance 1 les valeurs du mois de mai en considérant que le mois en cours (juin) sera des valeurs dans séance 2.

J'espère être assez explicite

4karell.xlsx (24.59 Ko)

Bonjour

Tu pourrais sans VBA présenter ton tableau comme dans ce fichier.

Une seule formule en B4 incrélentée sur toute la ligne remplirait ton tableau avec tes saisies

=SI(DECALER($A$7;DROITE(B3;1)*1;EQUIV(RECHERCHE("zz";$B$2:B2);$B$7:$K$7;0))="";"";DECALER($A$7;DROITE(B3;1)*1;EQUIV(RECHERCHE("zz";$B$2:B2);$B$7:$K$7;0)))

Cordialement

Bonjour

Bonjour à tous

Une variante...A tester.

Bye !

7karell-v1.xlsm (48.17 Ko)

Bonjour à vous 2,

Désolé de ne vous répondre seulement maintenant !

J'ai préféré utilisé le fichier avec macro (là où il n'y a pas de risque d'effacement des formules).

Tout fonctionne à merveille (j'ai entre temps modifié un peu le code pour l'adapter à une nouvelle structure de fichier).

J'ai aussi gardé la formule, pour plus tard, qui risque aussi de me servir.

Merci à vous

Rechercher des sujets similaires à "figer valeur mois precedent"