Erreur d'affichage dans ma ListBox

Bonjour à tous !

J'ai continué à avancer mon projet, mais j'ai un petit soucis.

J'ai remplacé mes 3 Listbox par une seule Listbox multicolonne.

Mon code à l'air de bien fonctionner car quand je modifie ma ComboBox ça m'affiche la bonne ligne, sauf que tout est décalé sur la droite. Du coup j'ai les noms sous les prénoms et les prénoms s’affiche pas... Ou se trouve l'erreur ?

Pareil avec ma ligne :

If Ws.Range("A" & J) Like "*" & critere And Ws.Range("B" & J) Like "*" & Me.TextBox_nom & "*" Then

Je devrais pouvoir affiner la recherche de la ComboBox, mais ça marche pas ... Mais ça beug pas non plus lol !

Merci à tous, bisous

24resshum.xlsm (43.91 Ko)

J'ai trouvé ma première erreur ! et comme il n'y a pas de réponse je la donne ici.

Il fallait modifier la ligne :

.List(.ListCount - 1, i) = Ws.Cells(J, i) par .List(.ListCount - 1, i - 1) = Ws.Cells(J, i) tout simplement

Me reste plus qu'à trouver la deuxième, qui consiste à une fois la compagnie choisie de pouvoir affiner la recherche par nom...

C'est déjà ce que fait la macro non ?

Oui mais non

Enfaite une fois la compagnie choisie, j'aimerais que quand je modifie ma ListBox_nom, ça m'affine ma recherche par nom dans la compagnie choisie par la ComboBox_compagnie ^_^

Imagine qu'il y est 1000 nom dans la compagnie .... Tout ne passe pas dans ma ListBox

comme ceci ?

32resshum-3.xlsm (29.67 Ko)

Et voilà solution trouver !

Alors dans un premier temps j'ai changer cette formule

If Ws.Range("A" & J) Like "*" & compagnie & "*" And Ws.Range("B" & J) Like "*" & nom & "*" Then

par

If Ws.Range("A" & J) Like "*" & compagnie & "*" And _

Ws.Range("B" & J) Like "*" & nom & "*" Then

A ce point la quand je choisissais une lettre dans la TextBox_nom et qu'ensuite je choississais la compagnie, ça me triais bien ma recherche par compagnie. Mais je devais à chaque fois changer de compagnie pour faire une nouvelle recherche.

Alors J'ai créée un Label_recherche , et ajouter des macros qui a chaque fois que Combo_Box et TextBox changeais ça cliquais sur mon Label, qui faisait un reste des Box.

Du coup quand je changeais cette fois de compagnie, ma TextBox_nom se vidais pas, alors j'ai tout simplement rajouter TextBox_nom = "" à chaque fois que ComboBox_compagnie_Change() + ListBox_recherche.Clear quand la TextBox_nom était vide.

Et voilà le tour est joué !!!

P.S : Je met en pièce jointe le fruit de ma labeur, si jamais ça pourrait servir à qqn


Ah bas on a poster en même temps Machin ^^

Le tiens parcontre quand tu fais une recherche par nom, et que tu efface la ListBox_nom ensuite ça t'affiche tout le tableau, alors que moi ça le vide

Merci quand même d'avoir prit un peu de temps pour moi quand même

Bisous


Regarde ma solution Machin, mon codage est quand même + simple que le tiens

34resshum-v004.xlsm (47.84 Ko)

Je ne suis pas rentré dans le détail, j'ai adapté ton code pour obtenir le résultat escompté mais si tout marche alors it's perfect

Rechercher des sujets similaires à "erreur affichage listbox"