Différence entre deux plages de données sans tenir des cases vides

Bonjour à tous,

Je souhaiterais obtenir de l'aide pour le problème suivant :

J'ai dans une plage A1:A5 des prix d'achat (toutes les cases sont remplies)

dans une plage B1:B5 des prix de vente (j'ai des cellules vides quand la ligne n'a pas été vendue)

Dans une plage C1:C5, les différences entre les prix de vente et les prix d'achat (cellule vide si la ligne n'a pas été vendue)

Je souhaiterais exprimer en pourcentage (dans une case C6 par exemple) la différence entre le total de la plage B1:B5 et la plage A1:A5 en prenant compte uniquement les cases non vides de la plage C1:C5

J'espère avoir été clair.

Merci d'avance de votre aide

Bonjour,

habitude à prendre dès le début

eric

Oups ! Désolé, je prépare ça et je le joins à mon prochain message.

Merci de l'info,

Cordialement

Et voilà,

encore merci d'avance

Quelle opération (avec les cellules) te permet d'obtenir 0.2 ?

L'opération serait (C7+C9+C11)/(A7+A9+A11)

ça fait 0.2

=SOMME(C7:C11)/SOMME.SI(C7:C11;">0";A7:A11)

eric

Merci beaucoup Eric, tu m'as fait faire un grand pas.

Petite remarque ou subtilité, mon calcul ne doit prendre les cases > 0 mais les cases différentes de 0 car je peux avoir des cases négatives dans la colonne C (que je souhaite prendre en compte) ... Comment je peux traduire cette subtilité sur excel.

Merci d'avance de ton aide et de ta patience.

Merci Eric, j'ai cherché et j'ai trouvé le signe <> pour différent que j'ai modifié dans ta formule et ça fonctionne ...

Bonne soirée à toi

Rechercher des sujets similaires à "difference entre deux plages donnees tenir cases vides"