Définir la dernière ligne dans un lien entre fichiers

Bonjour à tous

pas simple de faire simple titre...

La problématique est facile à résoudre en VBA, mais en EXcel seulement je sèche.

J4ai un fichier qui fait appel dans certaines cellules à un autre par une recherchev.

Mais cet autre a un nombre de ligne qui change souvent.

Comment écrire dansune cellule résultat qui prend la cellule A13 en référence pour sa recherche dans le fichier Source, sur une étendue variable (ici 500 lignes, 26 colonnes):

= RECHERCHEV(A13;'[Monfichiersource.xls]Feuil1'!$A1:$Z500;13;faux) si mes 500 enregistrements sont demain 450, 621, etc..?

Est ce possible ?

Merci de vos lumières !

Bonjour,

Ta colonne à telle une entête ? Car la plage n'est pas ce qui dérange le plus tu peux mettre une plage monstrueusement grande sa ira bien mais ce qui dérange c'est la "combientième colonne ?".

Dans ton exemple 13.

Pour obtenir cette valeur automatiquement utilise EQUIV()

=EQUIV("Entête de ta colonne";$1:$1;0)

Dit moi ci cela répond à ton problème.

Cdlt,

Bonjour,

Je ne sais pas si tu parles de lignes ou de colonnes ...

Pour obtenir la dernière ligne ...tu peux adapter la formule suivante :

SOMMEPROD(MAX((LIGNE(A1:A20))*(A1:A20<>"")))

En espèrant que cela t'aide ...

Edit : Salut VH_AE ..

James007 a écrit :

Bonjour,

Pour obtenir la dernière ligne ...tu peux adapter la formule suivante :

SOMMEPROD(MAX((LIGNE(A1:A20))*(A1:A20<>"")))

En espèrant que cela t'aide ...

Bonjour James,

Depuis le temps que je la cherche celle là.

C'est gentil

VH_AE a écrit :
James007 a écrit :

Bonjour,

Pour obtenir la dernière ligne ...tu peux adapter la formule suivante :

SOMMEPROD(MAX((LIGNE(A1:A20))*(A1:A20<>"")))

En espèrant que cela t'aide ...

Bonjour James,

Depuis le temps que je la cherche celle là.

C'est gentil

Ravi que cette formule puisse t'aider ...

Surtout pour un mec aussi sympa que toi ...

Cà fait encore plus plaisir ...

Rechercher des sujets similaires à "definir derniere ligne lien entre fichiers"