Chercher plusieurs mots dans une cellule

Bonjour,

Je viens de nouveau faire appel à vos lumières pour un problème dont je ne trouve pas de solution en ligne.

Le tableur est en PJ.

Je souhaite qu'en colonne C, pour chaque ligne, connaitre le profil de la personne, en fonction de sa réponse (colonne B), il y a 4 réponses max (colonne B).

Exemple en C2 : Si la cellule B2 contient le mot "rendement", alors inscrire "rendement" en C2, si B2 contient le mot "sécurité", alors inscrire "Sécurité" en C2...

J'ai trouvé un sujet sur ce forum se rapprochant de ma demande mais concerne 1 seul mot : https://forum.excel-pratique.com/excel/formule-pour-trouver-un-mot-d-une-phrase-dans-une-cellule-t27794.html

Merci pour votre aide,

Excellente journée,

Landry

180profil.xlsx (8.76 Ko)

Bonjour le forum,

C2 :

=SIERREUR(SI(CHERCHE("rendement";B2;1)>0;"rendement";"");"")&SIERREUR(SI(CHERCHE("plaisent";B2;1)>0;"plaisent";"");"")&SIERREUR(SI(CHERCHE("sécurité";B2;1)>0;"sécurité";"");"")&SIERREUR(SI(CHERCHE("réputation";B2;1)>0;"réputation";"");"")

Bonjour Mbbp, c'est parfait, bravo.

Merci pour la réponse rapide.

Je vous souhaite une excellente journée.

A+

Rechercher des sujets similaires à "chercher mots"