Calculer le prochain jour OUVRABLE

Bonjour à tous,

J'essaie en vain de trouver la solution au problème suivant :

En matière sociale il existe souvent des délais de réflexion. Quand ce délai expire un samedi, un dimanche ou un jour férié, le délai est automatiquement prorogé au 1er jour OUVRABLE (cad du lundi au samedi) suivant.

Pour résumer : Date de fin de délai = Date initiale + durée de réflexion

Mais si Date de fin de délai = samedi ou dimanche ou jour férié alors Date de fin délai = prorogation jusqu'au 1er jour ouvrable suivant.

Je vous remercie par avance de vos propositions (fonctions ou vba)

Bonjour,

Quelque chose comme ça ?

=SI(JOURSEM(C3+B3)=1;C3+B3+1;SI(JOURSEM(C3+B3)=7;C3+B3+2;C3+B3))

( Les jours de la semaine commence au dimanche pour Excel =) )

Ci-joint un fichier

137datebutoir.xlsx (9.24 Ko)

Bonjour le forum,

=SERIE.JOUR.OUVRE(A1;1;feries)

Bonjour @ tous,

sur le fichier de notre ami Watemark :

=SERIE.JOUR.OUVRE.INTL(C3;B3;1;Feries)

@ + +


Watewmark a écrit :

( Les jours de la semaine commence au dimanche pour Excel =) )

pour dire à Excel que les jours de la semaine commencent Lundi JOURSEM(Date;2)

R@chid a écrit :

pour dire à Excel que les jours de la semaine commencent Lundi JOURSEM(Date;2)

Génial ça je ne savais pas Merci !

Merci à tous d'avoir tenté de trouver une solution !

Watewmark a écrit :

Bonjour,

=SI(JOURSEM(C3+B3)=1;C3+B3+1;SI(JOURSEM(C3+B3)=7;C3+B3+2;C3+B3))

C'est un bon départ ! Mais cela ne gère pas les jours fériés.

R@chid a écrit :

Bonjour @ tous,

sur le fichier de notre ami Watemark :

=SERIE.JOUR.OUVRE.INTL(C3;B3;1;Feries)

La fonction SERIE.JOUR.OUVRE.INTL ajoute, me semble-t-il un nombre de jours OUVRES aprés une date. Ce qui ne correspond à ma demande puisque je désire ajouter un jour supplémentaire si la date calculée tombe un samedi ou un dimanche ou un jour férié.

mbbp a écrit :

Bonjour le forum,

=SERIE.JOUR.OUVRE(A1;1;feries)

Votre approche, que j'ai légèrement modifiée, me donne satisfaction ! Merci !

La formule retenue est :

=SERIE.JOUR.OUVRE(A3+B3-1;1;JF)

Avec :

A3 : Date initiale

B3 : Délai de réflexion

JF : Plage des jours fériés

Je renouvelle mes remerciements aux participants !

Re,

c’était pas de notre faute, c’était la faute de l'absence du fichier exemple avec résultats escomptés calculés manuellement.

@ + +

R@chid a écrit :

Re,

c’était pas de notre faute, c’était la faute de l'absence du fichier exemple avec résultats escomptés calculés manuellement.

@ + +

Cela l'adage très connu "un fichier vaut mieux qu'un long discours..." ( ) vous avez absolument raison !

Mea-culpa !

Rechercher des sujets similaires à "calculer prochain jour ouvrable"