Calculer le n.de cellules d'une même couleur

Bonjour,

Tout est dit dans le titre, j'ai un tableur avec certaines cellules avec un fond rouge(alerte signalant une erreur) et je cherche à savoir s'il existe une formule permettant d'avoir le nombre de cellules ROUGE.

Par exemple un tableau A1:F30 avec genre =NB(cellule fond rouge) ?

Si cela n'existe pas, il y a peut-être autre moyen ?

Excellente journée à tous

Bonjour,

Les cellules en fond rouge sont elles sur mise forme conditionnelle ?

Si c'est le cas, il te suffit de prendre la formule de la MFC et de la modifier pour te faire la somme,

sinon par une fonction en VBA

Bonjour Tonthon, toutes et tous,

Avec une fonction personnalisée dans VBA, ne fonctionne pas si c'est des MFCs.

Voir fichier ci-joint.

Cordialement


Édit: Salut M12,

23tonthon-v1.xlsm (15.90 Ko)

Bonjour le forum,

=NB(SI(ESTERREUR(A1:F30);1;""))

Formule matricielle à valider avec CTRL MAJ ENTREE

RE

Je suis ravi d'apprendre que la solution existe.

Dans mon cas, il s'agit bien de cellules qui se mettent sur fond rouge suite à une MFC comparant 2 cellules.

Du coup, si j'ai bien compris, la solution VBA ne fonctionne pas mais malheureusement je ne "pige" pas comment modifier la formule pour avoir la somme dans une cellule et l'affichage en rouge des erreurs

la règle actuelle est =G5<>X5 /fond rouge/ s'applique à

A vous lire

une solution en utilisant la notion de tabeau

Ou :

=SOMMEPROD(--ESTERREUR(A1:F30))
gullaud a écrit :

une solution en utilisant la notion de tabeau

Désolé, je n'avais pas vu ta solution entre temps !

Cela ne fonctionne pas dans le cas présent car il n'y a pas d'affichage "erreur" cf la règle du MFC qui compare 2 cellules.

En attendant....

Re,

Vaudrait mieux avoir un exemple pour travailler.

Ton tableau (A1:F30) et la formule =G5<>X5, alors c'est confu pour distinguer la MFC

Effectivement, on pense exprimer clairement un cas....

Ci-joint le tableur explicitant le problème.

J'ose ? C'est possible de le faire avec différences couleurs ? n.rouge.....n.jaune ?

Merci d'avance

=SOMMEPROD(--(B6:K30<>M6:V30))
mbbp a écrit :
=SOMMEPROD(--(B6:K30<>M6:V30))

Effectivement c'est tout simple mais cela ne m'était pas venu à l'idée.

Tonthon

Rechercher des sujets similaires à "calculer meme couleur"