Calculer heures

Bonjour !

Dans une seule et même cellule j'ai : 10:00 à 22:00. Ce sont des heures.

Dans une autre cellule, je voudrais qu'apparaisse le nombre total des heures, soit ici 12.

Est-il possible de faire une soustraction dans une seule et même cellule ?

Il faut prendre en considération que 00:15 doit être égal à 0.25, 00:30 doit être égal 0.5 et que 00:45 doit être égal 0.75 pour que le calcul soit juste.

Merci d'avance, Noëlie.

Bonjour,

on met la cellule contenant 10:00 à 12:00 au format heure puis dans la cellule de formule on met

=(DROITE(B4;5)-GAUCHE(B4;5))
noelie a écrit :

Il faut prendre en considération que 00:15 doit être égal à 0.25, 00:30 doit être égal 0.5 et que 00:45 doit être égal 0.75 pour que le calcul soit juste.

je n'ai pas compris cette partie

Merci beaucoup je vais essayer de suite.

Quand on a un horaire de 9h45 à 15h30 par exemple, on traduit par 9,75 à 15,5.

En gros, 15min = 0.25

30min = 0.50

45minj = 0.75

Bonjour,

Voir fichier pour plus d'informations.

=SI($C2<$B2;$C2-$B2+1;$C2-$B2)*24
20noelle.xlsx (8.06 Ko)

SUPER !

Merci beaucoup pour l'aide précieuse !

Rechercher des sujets similaires à "calculer heures"