Calcul impôt marginal

Bonjour,

Je suis en train de travailler sur un outil de simulation d'investissement.

J'ai besoin de calculer en une seule formule l'impôt marginal que va générer le revenu supplémentaire lié cet investissement.

Exemple:

L'investissement va générer 15 000 euros de revenus en plus. Quel sera l'impact fiscal en fonction de sa tranche d'impôt.

le barème de l'impôt étant le suivant :

Jusqu'à 9 700 € = 0 %

De 9 700 € à 26 791 € = 14 %

De 26 791 € à 71 826 € = 30 %

De 71 826 € à 152 108 € = 41 %

Plus de 152 108 € = 45 %

Exemple : une personne a déjà un revenu de 70 000 euros.

Les 15 000 euros seront imposé pour un montant de 1826 à 30% et 13 174 euros à 41 %.

merci d'avance pour votre aide.

Sébastien.

Bonjour le forum,

Pour un célibataire :

Revenu 70 000 : IRPP : 13 255

Revenu 85 000 : IRPP : 17 820

50irpp-2016.xlsx (19.01 Ko)

Le problème c'est qu'il faudrait que je puisse avoir ce calcul en une seule formule.

En effet, je dois intégrer ce calcul dans une feuille qui constitue un prévisionnel sur plusieurs années.

merci,.

=SOMME(($C$5:$C$9-$C$4:$C$8)*(Revenu-$B$4:$B$8+ABS(Revenu-$B$4:$B$8)))/2

Formule matricielle.

Mais ne tient pas compte du QF ni du plafonnement du QF.

irpp

Bonjour à tous

Une réponse à la question initiale avec une fonction personnalisée.

Bye !

34classeur1-v1.xlsm (21.34 Ko)

Le code de gmb fonctionne parfaitement.

Nous arrivons au même résultat : impôt supplémentaire : 4 565 €.

Il ne faut pas oublier que le revenu brut bénéficie d'une réduction de 10% plafonnée. (Formule F3 du fichier IRPP 2016).

irpp v3

Super travail.

est ce que c'est possible de faire évoluer ce calcul en fonction du nombre de parts ( 1 ou 2 parts) ?

Il faut tenir compte de la composition de la famille, mais également d'une éventuelle décote.

J'ai pas du compris ta formule . Tu as caché des feuilles ?

c'est quoi la référence: ' '!J9

ALT F11

Feuil2 : Visible

Fenêtre Propriétés

Remplacer 0 par 1

Rechercher des sujets similaires à "calcul impot marginal"