Calcul d'une valeur à partir de deux conditions

Bonjour,

Le fichier ci-joint consiste à calculer la valeur "M" de la colonne G à partir du signe des colonnes D et E comme le montre les quatre conditions suivantes :

- Si Dx>0 et Dy>0 alors M=valeur de G1

- Si Dx>0 et Dy<0 alors M=200-valeur de G1

- Si Dx<0 et Dy<0 alors M=200+valeur de G1

- Si Dx<0 et Dy>0 alors M=400-valeur de G1

Pourriez-vous m'aider à trouver la solution à ce problème ?

Merci par avance.

Bonjour,

Que se passe-t-il si Dx ou Dy =0 ?

capture

Bonjour Eric,

On pourra inclure Dx=0 ou Dy=0 à la première condition.

Cordialement.

Si VBA est autorisé (fichier .xlsm) :

Function ValeurM(ByVal VDx As Double, ByVal VDy As Double, ByVal VG1 As Double) As Double

         If VDx = 0 Or VDy = 0 Then ValeurM = VG1
         If VDx > 0 And VDy > 0 Then ValeurM = VG1
         If VDx > 0 And VDy < 0 Then ValeurM = 200 - VG1
         If VDx < 0 And VDy < 0 Then ValeurM = 200 + VG1
         If VDx < 0 And VDy > 0 Then ValeurM = 400 - VG1

End Function

Bonjour à tous ,

On pourra inclure Dx=0 ou Dy=0 à la première condition.

Donc j'en conclus que vous vous en débrouillerez...

Sinon pour une réponse stricte à votre question, essayez : =CHOISIR(1+2*(D2>0)+(E2>0);200+F2;400-F2;200-F2;F2)

Salut Eric et Mafraise,

Merci pour vos suggestions, je vais me débrouiller, je vois clair maintenant !

Bien à vous

Re,

Avec l'inclusion du cas Dx=0 ou Dy=0

cela donnerait : =SI(D2*E2;CHOISIR(1+2*(D2>0)+(E2>0);200+F2;400-F2;200-F2;F2);"cas-zéro")

Rechercher des sujets similaires à "calcul valeur partir deux conditions"