Caclule avec condition

bonjour,

je voudrais effectuer ce qui suit ;

calculer dans F6 le nombre de fois ou le critère NCR apparait sous condition que le mois de la colonne "DATE" corresponde au moi de la cellule F5;

MERCI

LE FICHIER EST LE SUIVANT :

8classeur2.xls (13.50 Ko)

Bonjour,

Il aurait été préférable que tu postes directement dans le Forum Excel VBA pour avoir plus de chances d'être lu et donc d'avoir une réponse.

Je te propose cette formule :

=SOMMEPROD(($C$6:$C$11="NCR")*(MOIS($D$6:$D$11)=MOIS($F$5)))

@+

merci pour l'instant ca marche!!!!

ça marche très bien sauf que si j'ai des attributs dans ma colonne qui ne sont pas des dates (caractères) il m'affiche #VALEUR! dans ma cellule de calcule.

Merci de votre aide

Bonsoir,

Une solution avec une formule matricielle :

=SOMME(SI(ESTNUM($D$6:$D$11);($C$6:$C$11="NCR")*(MOIS($D$6:$D$11)=MOIS($F$5))))

Formule matricielle à valider par CTRL + MAJ + ENTREE

@+

Rechercher des sujets similaires à "caclule condition"