Associer un chiffre à un mot

Bonjour !

Je voudrais pouvoir associer un chiffre à un mot.

Par exemple :

1 = bonjour

2 = aurevoir

3 = salut

Ca ce complique, puisque je voudrais que dans une même cellule, lorsque je tape "1 2 3", s'affiche "bonjour aurevoir salut".

Est-ce possible ?

noelie a écrit :

... je voudrais que dans une même cellule...

Moi je sais pas

Un essai en retour avec la fonction CHOISIR()

Leakim

312noelie.xlsx (9.14 Ko)

Est-ce que tu peux m'expliquer comment tu fais ta liste de choix ?

Le soucis, c'est que je voudrais que quand je tape 1 2 3, tous les mots s'affiche à la suite.

Par exemple :

En A1 : 1 2 En B1 : bonjour aurevoir

En A2 : 1 3 En B2 : bonjour salut

Re,

avec

=SI(NBVAL(B3)=1;CHOISIR(B3;"Bonjour";"Au revoir";"Salut");CONCATENER(CHOISIR(GAUCHE(B3;1);"Bonjour";"Au revoir";"Salut");" ";CHOISIR(DROITE(B3;1);"Bonjour";"Au revoir";"Salut")))

a me redire,

Leakim

240noeliev002.xlsx (9.26 Ko)

Ha c'est pas mal ça ! Ca risque d'être compliqué si j'ai des données à ajouter mais ça m'a l'air super !

Par contre, ça me dit qu'il y a une erreur quand je sélectionne 2 chiffres ...

Bonjour,

C'est presque normal puisque l'on passe par une liste...

Si tu veux saisir directement la combinaison de chiffres, il faut sortir de la liste. Il te faudra mettre un espace entre tes chiffres (à vérifier). Tu ne dois saisir que 1,2 ou 3 dans la cellule, sinon tu obtiendras des erreurs de valeurs dans la formule.

Pour ôter la liste, tu sélectionnes la cellule, cliques droit et supprimes.

A me redire,

Leakim

Bonjour,

Une proposition à étudier pour tes besoins.

Liste de validation avec multiples sélections (ajout/suppression).

Cdlt.

Rechercher des sujets similaires à "associer chiffre mot"