Aide sur formule Excel

bonjour le forum, bonjour à tous,

j'ai ecrit cette formule pour faire +1 à chaque ligne (partie en gras)

=SI(L4=" ";" ";INDEX(INDIRECT(R$1&"!$B$7:$B$200");EQUIV((L4+1);INDIRECT(R$1&"!$B$7:$B$200");0)))

mais je ne sais pas comment traiter le cas ou je passe de 15 à 18 par exemple, les résultats s’arrêtent dans ce cas à la ligne qui a le 15 et comme il n'y a ni 16 , ni 17, alors le 18 n'est pas trouvé.

comment faire pour dire à la formule d'aller au suivant immédiat, de telle sorte que si j'ai

2

6

3

1

5

il me les aligne = 1 - 2 - 3 - 5 - 6

donc à défaut du 4, il passe au 5.

merci.

Pedro.

Bonsoir,

Avec un fichier d'exemple ce serait plus simple pour comprendre,

A te relire,

RE,

voici.

sur la feuille 13 , colonne B , on passe du 192515 au 192518.

donc sur la feuille "valid" le 192518 n’apparaît pas puisqu'il n'y a pas les 192516 et 192517.

comment modifier la formule pour qu'il passe au suivant si le lot +1 n'existe pas?

merci.

Pedro.

9test.xlsx (66.23 Ko)

Salut Tchio77, dudesson

essaye ça

Si la valeur de l'argument type est -1, la fonction EQUIV trouve la plus petite valeur qui est supérieure ou égale à celle de l'argument valeur_cherchée.

Rechercher des sujets similaires à "aide formule"