Aide pour formule qui affiche le premier élément, et suivant

Bonjour,

je bloque sur une formule permettant d'afficher les éléments d'une colonne dans une autre par ordre

Exemple

Colonne A Colonne C (résultat attendu)

VERT VERT

jaune jaune

ROUGE ROUGE

BLEU BLEU

MARRON MARRON

violet violet

NOIR NOIR

BLANC BLANC

Sauf que certains éléments de la colonne A, peuvent ne pas être présent, ce qui explique la formule compliquée

Colonne A Colonne C (résultat attendu)

VERT VERT

MARRON

BLANC

MARRON

BLANC

J'ai déjà la formule pour le premier élément de la colonne A, à afficher dans la colonne C (entre accolades avec Ctrl Shift + entrée)

{=INDEX(D27:D34;EQUIV(VRAI;D27:D34<>"";0))}

Pour les autres éléments, j'ai fait cette formule, mais cela ne marche pas, il doit y avoir un truc qui cloche (entre accolades avec Ctrl Shift + entrée)

{=INDEX(DECALER(D27;EQUIV(F20;D27:D34;0););EQUIV(VRAI;DECALER(D27;EQUIV(F20;D27:D34;0);)<>"");0)}

Je mets un fichier pour mieux comprendre

Merci pour votre aide,

21formule.xlsx (16.78 Ko)

Bonjour,

c'est pas clair !!?!?!

tu parles déjà de la colonne A alors qu'elle est vide.

je ne sais pas pourquoi VERT JAUNE VERT JAUNE en colonne G pourquoi les doublons ?

@ te relire


Bonjour,

c'est pas clair !!?!?!

tu parles déjà de la colonne A alors qu'elle est vide.

je ne sais pas pourquoi VERT JAUNE VERT JAUNE en colonne G pourquoi les doublons ?

@ te relire


Bonjour,

c'est pas clair !!?!?!

tu parles déjà de la colonne A alors qu'elle est vide.

je ne sais pas pourquoi VERT JAUNE VERT JAUNE en colonne G pourquoi les doublons ?

@ te relire

Bonjour

je m'explique

j'ai des couleurs dans une colonne au nombre de 8

Dans une seconde colonne, je cherche à afficher les couleurs qui sont présentes, en sachant que les couleurs de la colonnes A ne sont parfois pas toutes présentes.

Je peux avoir dans la colonne A par exemple

VERT

jaune

ROUGE

BLEU

MARRON

violet

NOIR

BLANC

Et dans ce cas je dois avoir dans l'autre colonne

VERT

jaune

ROUGE

BLEU

MARRON

violet

NOIR

BLANC

Mais je peux avoir dans la colonne A

VERT

MARRON

BLANC

et dans ce cas, je cherche à avoir dans l'autre colonne,

VERT

MARRON

Blanc

j'espère que je me suis mieux expliqué, c'est aussi pour cela que j'ai mis un fichier pour mieux comprendre

merci

Re,

en G20 :

=SIERREUR(INDEX(D$27:D$41;PETITE.VALEUR(SI(D$27:D$41<>"";LIGNE(INDIRECT("1:"&LIGNES(D$27:D$41))));LIGNES($20:20)));"")

@ valider par Ctrl+Shift+Enter

@ tirer vers le bas

@ + +

Merci à toi,

t'es trop fort, vraiment

j'ai pas mal galérer pour essayer de trouver la formule

Un grand merci

Rechercher des sujets similaires à "aide formule qui affiche premier element suivant"