Aide formule somme

Bonjour à tous

je viens solliciter votre aide pour une formule afin d'obtenir une somme sur des colonnes décalées

dans l'exemple joint, 3 ou 4 colonnes mais en réalité, une centaine

Merci de votre aide

11formule.xlsx (7.91 Ko)

Bonjour,

Peut-être avec :

=SOMME.SI(B3:Z3;"B";B4:Z4)/SOMME.SI(B3:Z3;"A";B4:Z4)

Bonjour

Merci de votre réponse mais il n'y a ni A ni B

c'est juste pour mettre en évidence le décalage des colonnes

bonjour,

une solution via une fonction personnalisée

Function f4p4(r)
    For i = 1 To r.Columns.Count Step 3
        n = n + r.Cells(1, i + 1)
        d = d + r.Cells(1, i)
    Next i
    f4p4 = n / d
End Function

à utiliser de la manière suivante pour ton exemple

=f4p4(H4:O4)

H4:O4 est la plage dont il faut prendre la somme des 1ers éléments par groupe de 3 comme dénominateur et le la somme des 2èmes éléments au numérateur.

Bonjour h2so4

Je ne comprend pas le décalage entre mon résultat et le tien

voir fichier

il faut remplir le cellules en rouge

Merci


Re h2so4

Désolé mais c'est bien ma formule qui posait problème

La tienne fonctionne a merveille

Cela fais deux jours que je cherche avec un sommeprod

Merci beaucoup

5formule.xlsm (27.18 Ko)

bonjour,

le première cellule de la plage doit être le premier element de la somme à mettre au dénominateur.

j'ai pas compris ce que tu voulait mettre dans les cellules rouges.

Rere

Dans les cellules rouges, je met de 1 à 4

Ca fonctionne nickel

Encore merci

Rechercher des sujets similaires à "aide formule somme"