Aide formule

Bonjour,

je cherche une formule pour effectuer :

si je rentre un chiffre dans une cellule "exemple A1" cela va me chercher une valeur pour l'inscrire dans la "cellule exemple B1".

a savoir que le chiffre dans la cellule "exemple A1" va varier de 1 à 20 et que selon le chiffre la valeur rechercher (dans un tableau déjà rempli) sera différente.

exemple en gros - si "1" dans "A1" = "tel valeur de cellule" dans "B1"

- si "2" dans "A1 = "tel autre valeur d'autre cellule" dans "B1"

merci d'avance

Un petit fichier pour plus de clarté stp

malheureusement je ne l'ai pas sous la main

actuellement j'utilise une formule :

=SI(ESTNUM(CHERCHE("1";I7));Feuil1!G3)

mais je n'arrive pas a faire plusieurs variable

je recherche la même chose mais avec :

si "2" dans telle cellule rechercher "telle cellule", si "3" rechercher "tel cellule".....

Bonjour Pacino51, le forum

la valeur qui doit s'afficher est située dans une base de donnée?

Si c'est le cas tu pourrais utiliser la formule RECHERCHEV(A1;les colonnes et lignes où sont stockées les données; le numéro de la colonne où sont stockées les références recherchées;FAUX)

Cordialement

la valeur est dans un tableau de données "feuille 1"

un essai en pièce jointe

Est ce que j'ai bien compris ta demande?

Voir pièce jointe.

Del_Fine

4pacino51.xlsx (8.30 Ko)

Belle proposition Del Fine mais si j'ai bien lu la numérotation va de 0 à 20. Avec la fonction SI ta formule va être lourde

Cordialement

Belle proposition Del Fine mais si j'ai bien lu la numérotation va de 0 à 20. Avec la fonction SI ta formule va être lourde

Cordialement

Je vais regarder ta proposition etsije! Qu'entends tu par "ta formule va être lourde"?

Fichier volumineux ? Temps d'exécution ?

Merci pour tes précisions !

Si j'ai bien compris tu effectue une demande pour chaque possibilité de valeur (de 1 à 20 dans le cas exposé en exemple) donc 20 fois SI

Cordialement

Bonjour à tous,

Si j'ai bien compris le problème ...

Index répond à cette interrogation ...

En espèrant que cela aide ...

Merci cela fonctionne

Merci cela fonctionne

Surpris ... ???

Rechercher des sujets similaires à "aide formule"