Réconciliation de deux feuilles

Bonjour tout le monde !
J'ai besoin d'un peu d'aide, je suis assez perdue sur un truc que j'ai besoin de faire !
Alors, en gros, j'ai un fichier avec deux feuilles. La première a 7000 lignes avec plein de colonnes dont une colonne nom et une prénom. La deuxième fait 4500 lignes et trois colonnes nom, prénom, adresse mail.

En gros il faudrait que j'ajoute les mails qui correspondent aux noms/prénoms sur la première feuille (ou que je fasse une troisième feuille avec toutes les colonnes de la première feuille + une avec les mails au bon endroit)

En image :
Feuille 1

MarineLastname1Autres infos
AxelLastname2
JeremyLastname3
PerrineLastname4
Candice Lastname3

Feuille 2

MarineLastname1
Adresse mail
Axel
Lastname2Adresse mail
PerrineLastname4Adresse mail

Et ce qu'il me faudrait a la fin :

MarineLastname1Infos
Adresse mail
AxelLastname2Adresse mail
JeremyLastname30
PerrineLastname4Adresse mail
CandiceLastname50

Si quelqu'un a une solution miracle je lui en serai grandement reconnaissante ! Merci d'avance !

Bonjour Scape,

Voyez si la solution proposée dans le fichier joint peut vous aider

Utilisez une formule du type en feuille "Feuille1"

=SI(ESTERREUR(EQUIV(A1&B1;$'Feuille 2'.D:D;0));"0";INDIRECT("Feuille 2.C"&EQUIV(A1&B1;$'Feuille 2'.D:D;0);1))

Et en "Feuille 2"

=CONCAT(A1;B1)
14scape.ods (10.82 Ko)

Super ! Ca a l'air d'être ça ! Je vérifie avec mes fichiers lundi au boulot mais je pense que c'est tout bon :D
Merci beaucoup vous me sauvez !

Tout marche super ! Merci encore !

Rechercher des sujets similaires à "reconciliation deux feuilles"