Formule dates Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
m
mariegrngr
Jeune membre
Jeune membre
Messages : 17
Inscrit le : 5 juillet 2017
Version d'Excel : 2010

Message par mariegrngr » 5 juillet 2017, 16:03

Bonjour,

Je souhaite pouvoir avoir les dates de début et fin de formation suivant les dates de début et de fin de contrat rentrées. Jusqu'ici tout va bien.
Mais je souhaite également prendre en compte une autre date (en vert), la date à prendre en compte pour le changement de rémunération, qui doit alors "couper" l'année en cours...
J'y arrive lorsque l'interruption se produit au cours de la seconde année, mais pas du tout quand elle intervient au cours de la 1ère année car il reprend en compte l'interruption...(cellule en orange)

Merci beaucoup si vous pouvez m'apporter votre aide.
sim.xlsx
(10.63 Kio) Téléchargé 17 fois
m
mariegrngr
Jeune membre
Jeune membre
Messages : 17
Inscrit le : 5 juillet 2017
Version d'Excel : 2010

Message par mariegrngr » 7 juillet 2017, 15:26

Personne pour un p'tit coup de pouce ?
J
JFL
Membre impliqué
Membre impliqué
Messages : 1'335
Inscrit le : 1 avril 2011
Version d'Excel : 2010 FR, 2013 FR

Message par JFL » 8 juillet 2017, 18:50

Bonjour et bienvenue sur le Forum !

Je pense que la communauté trouvera solution à votre problème pour peu qu'il soit explicitement formulé. Car là......c'est un tantinet obscur ! ;;)

Exemples :

Date du contrat : 1/6/2030 au 31/5/2030
En l'état c'est impossible !
mariegrngr a écrit :J'y arrive lorsque l'interruption se produit au cours de la seconde année, mais pas du tout quand elle intervient au cours de la 1ère année car il reprend en compte l'interruption...(cellule en orange)
Votre fichier exemple laisse à penser tout l'inverse ! Résultat qui semble exact avec la césure en 1ère année mais souci sur la deuxième année.

Une petite ré-explication me semble nécessaire.
Cordialement

JF
m
mariegrngr
Jeune membre
Jeune membre
Messages : 17
Inscrit le : 5 juillet 2017
Version d'Excel : 2010

Message par mariegrngr » 13 juillet 2017, 09:55

Merci de ta réponse et de tes explications, je ne suis effectivement pas très claire, je vais essayer de faire mieux !

J'ai des contrats de 2 ou 3 ans, la date de debut du contrat est saisie en L9, la date de fin est calculée automatiquement en N9.
En dessous, j'ai la répartition par année, les dates de début et de fin pour chaque année.

Le problème est que je dois prendre en compte la date en vert dans la répartition de ces années, cela marche très bien quand cela intervient sur la seconde année, mais pas quand il s'agit de la première année (les dates de la seconde année sont fausses, formule en orange). Il devrait y avoir 31/05/32.

J'espère avoir ete plus claire cette fois, je remets la tableau à jour en pièce jointe.

Merci beaucoup pour votre aide, je galère vraiment...
Copie de sim-1.xlsx
(10.63 Kio) Téléchargé 9 fois
m
mdo100
Membre dévoué
Membre dévoué
Messages : 891
Appréciations reçues : 39
Inscrit le : 25 mai 2013
Version d'Excel : 2010 FR

Message par mdo100 » 13 juillet 2017, 10:25

Bonjour mariegrngr, JFL,

Je ne suis pas sûr d'avoir tout compris, toutefois...

En "O14" ce ne serait pas plutôt comme ça qu'il faudrait écrire la formule !
=SI(DATE(ANNEE(M14)+1;MOIS(M14);JOUR(M14)-1)>N3;(DATE(ANNEE(M14)+1;MOIS(M14);JOUR(M14)-1));N3-1)
Ce qui donne bien la date du 31/05/2032.

Cordialement.
m
mariegrngr
Jeune membre
Jeune membre
Messages : 17
Inscrit le : 5 juillet 2017
Version d'Excel : 2010

Message par mariegrngr » 13 juillet 2017, 10:47

Bonjour mdo100,

Merci de ta réponse.

Cependant ta formule de correspond pas à mon problème.
Je souhaiterai que soit prise en compte la date en vert.

Par exemple : si la date en vert est le 01/02/2030, le contrat du 01/06/2028 au 31/05/2030
1ere année du 01/06/2028 au 31/05/2029
2ème année du 01/06/2029 au 31/01/2030 (pour prendre en compte la date en vert)
du 01/02/2030 au 31/05/2030

Pareil si la date en vert est dans la période couverte par la première année.
m
mdo100
Membre dévoué
Membre dévoué
Messages : 891
Appréciations reçues : 39
Inscrit le : 25 mai 2013
Version d'Excel : 2010 FR

Message par mdo100 » 13 juillet 2017, 11:12

Re,

Et pourtant !
mariegrngr V1.xlsx
(15.06 Kio) Téléchargé 2 fois
Capture.JPG
m
mariegrngr
Jeune membre
Jeune membre
Messages : 17
Inscrit le : 5 juillet 2017
Version d'Excel : 2010

Message par mariegrngr » 13 juillet 2017, 11:28

Merci mdo100 !! :D :D :D :D
Effectivement ca marche bien, je suis trop contente ! je vais enfin pouvoir finir ce travail.
Je reviens vers toi si je bloque encore dans la journée, en tout cas, merci beaucoup !
m
mariegrngr
Jeune membre
Jeune membre
Messages : 17
Inscrit le : 5 juillet 2017
Version d'Excel : 2010

Message par mariegrngr » 13 juillet 2017, 11:51

Joie de courte durée malheureusement... C'est pourtant presque ca... et j'avoue que je ne comprends plus grand chose !

A l'aide !!
Copie de sim-1.xlsx
(10.63 Kio) Téléchargé 6 fois
m
mdo100
Membre dévoué
Membre dévoué
Messages : 891
Appréciations reçues : 39
Inscrit le : 25 mai 2013
Version d'Excel : 2010 FR

Message par mdo100 » 13 juillet 2017, 12:51

Re,

Nouvel essai.

En "O14":
=SI(DATE(ANNEE(M14)+1;MOIS(M14);JOUR(M14)-1)>=FIN.MOIS(N3;-1)+1;N3-1;DATE(ANNEE(M14)+1;MOIS(M14);JOUR(M14)-1))
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message