Calcule plage horaire et temps moyens Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
Seb77
Membre habitué
Membre habitué
Messages : 119
Inscrit le : 7 juin 2015
Version d'Excel : 2010

Message par Seb77 » 19 mars 2016, 23:20

Bonjour,

je bloque sur 2 problèmes :

1- J'ai dans mon tableau des horaire de début et fin avec comme dernière colonne le calcul du temps entre ces dernières
mais lorsque l'heure de fin dépasse 23h59 j'ai une erreur :?

2- Je voudrais par la suite calculer le temps moyen de la colonne qui calcule le temps entre le début et la fin
mais le tableau évolue donc on ne peu pas donner une plage exacte

Je joins un fichier avec un peu plus de précision


Merci d'avance
calcul horaire et temps moyen.xlsx
(11.67 Kio) Téléchargé 22 fois
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'201
Appréciations reçues : 444
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 19 mars 2016, 23:58

Bonsoir,

Note-toi la formule ci-dessous, c'est la plus simple et la plus efficace pour calculer une durée (inférieure à 24h) sans se préoccuper de savoir si l'heure de fin est inférieure à l'heure de début (ce qui est le cas lorsqu'on passe minuit).
=MOD(E2-D2;1)
Je n'ai pas encore compris ta 2e question mais je vais la relire. :D

Cordialement.

Ça y est j'ai compris :D . On peut faire :
=MOYENNE(DECALER($L$2;;;NB(L:L)))
seb77_calcul horaire et temps moyen.xlsx
(11.73 Kio) Téléchargé 15 fois
Avatar du membre
Seb77
Membre habitué
Membre habitué
Messages : 119
Inscrit le : 7 juin 2015
Version d'Excel : 2010

Message par Seb77 » 20 mars 2016, 00:24

Parfait!!!

Une grand merci c'est nickel :D


Si je peux me permettre une dernière petite question :

Pour le calcule du temps de la colonne "L", est-ce que c'est possible d'avoir le résultat quand je rajoute ma ligne dans le tableau
ou je dois l'inclure dans mon code vba qui renseigne le tableau??

J'ai essayé de faire du copier coller du code que tu m'as donné
=MOD(E2-D2;1)
mais ca me mets plein de 00:00:00 et fausse ma moyenne :?
Avatar du membre
eriiic
Passionné d'Excel
Passionné d'Excel
Messages : 8'920
Appréciations reçues : 328
Inscrit le : 7 février 2010
Version d'Excel : 2010fr

Message par eriiic » 20 mars 2016, 00:27

Bonjour,

=MOYENNE(L:L) fonctionne.
Tu devais avoir un mauvais résultat à cause des temps négatifs que tu avais (les ######).
eric
En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.
(les Shadoks)

En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'201
Appréciations reçues : 444
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 20 mars 2016, 00:28

Modifie la formule Moyenne...
=MOYENNE(DECALER($L$2;;;NB.SI($L:$L;">0")))
ainsi, elle ne prendra pas les 0 en compte.
Avatar du membre
Seb77
Membre habitué
Membre habitué
Messages : 119
Inscrit le : 7 juin 2015
Version d'Excel : 2010

Message par Seb77 » 20 mars 2016, 00:51

Merci beaucoup pour les réponses et conseilles :D
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message