Supprimer ligne N/A Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
f
flo13
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 14 février 2017
Version d'Excel : 2016 FR

Message par flo13 » 10 août 2017, 15:49

Bonjour,

Mon tableau est bcp trop volumineux alors une image en pj :

Je fais des stats, à chaque fois je rajoute mon extraction à mon fichier. Dans ma colonne E, le nom de mes agents, déduit par une recherche V.
Ma question est quand ma recherche V donne "N/A", je voudrai que cette ligne soit supprimée. J'ai donc crée un bouton et essayé le code suivant :
Sub MAJ()
  On Error Resume Next
  Columns("A").SpecialCells(xlCellTypeFormulas, xlErrors).EntireRow.Delete
  On Error GoTo 0
End Sub
Celui ci supprime le contenu de mes lignes "N/A" mais me laisse une ligne blanche. Je voudrai qu'il supprime complètement la ligne.

Je vous remercie, si l'image n'est pas assez bien, je vais essayer de faire un autre fichier

Bonne après midi !
Capture.JPG
a
archer
Membre impliqué
Membre impliqué
Messages : 1'176
Appréciations reçues : 89
Inscrit le : 8 avril 2017
Version d'Excel : 2007/2010

Message par archer » 10 août 2017, 16:06

bonjour
moi j'ais pas N/A dans mes recherchev regarde ma formule
ex:=RECHERCHEV(L11;'nom des stations'!$A$1:$B$88;2;FAUX)
ca peux déjà résoudre un problème
A+
Maurice
Avatar du membre
bouben
Membre impliqué
Membre impliqué
Messages : 1'494
Appréciations reçues : 2
Inscrit le : 25 août 2014
Version d'Excel : 2010

Message par bouben » 10 août 2017, 16:09

Bonjour,

Ci-joint une proposition à tester et à adapter, en VBA.

Bon après midi

Bouben
SupprimeLigneNA.xlsm
(16.22 Kio) Téléchargé 24 fois
f
flo13
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 14 février 2017
Version d'Excel : 2016 FR

Message par flo13 » 10 août 2017, 16:23

Archer : si c'est du NA c'est normal car c'est autre chose qu'un agent, compliqué à expliquer mais merci de la réponse :)

Bouben : Parfait ! Ca fonctionne, j'ai adapté ça au bon numéro de colonne, et magique ! Merci !!!

Bonne fin de journée !
a
archer
Membre impliqué
Membre impliqué
Messages : 1'176
Appréciations reçues : 89
Inscrit le : 8 avril 2017
Version d'Excel : 2007/2010

Message par archer » 10 août 2017, 16:30

bonjour
pour supprimer une ligne mettre ROWS
A+
Maurice
Sub Test()
Dim Ilig As Long
Dim L As Long
Application.ScreenUpdating = False
Ilig = Range("A" & Rows.Count).End(xlUp).Row 'part de la dernière ligne
   For L = Ilig To 2 Step -1
      If IsError(Range("A" & L).Value) Then
         Rows(L).Delete
      End If
   Next
End Sub
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message